Problem with AMASSS

Hi everyone,

I am trying to use the AMASSS (part of Automated dental tools extension) and every time I try to run the segmentation the program is freezing. I am trying to segment a CBCT file saves as a GIPL file. At the bottom of the one section, it lists the time it takes to run but no matter what I try it always freezes and won’t continue. I was wondering if anyone is experiencing this issue or knows how to combat it. I don’t have too much experience using this program! Thank you in advance


I have try using it for a few weeks ago. I do not have much experience in using it as well. However, it work as normal for my case but it take very long time to run and complete the process. It took me around 2 hours to run the segmentation. To be clear, could you share how you do it by screenshot your working tab. so that I might have suggest what I have done.


I am using the newest slicer version: 5.4.0 (I’ve also tried some of the slightly older ones as well).

I load my CBCT scan as a .gpl file.

Click on modules → AMASSS
The node is selected as the scan I uploaded
Model’s Folder: I clicked on “download latest models” and after those are downloaded I place them into one folder and upload that for the model’s folder section

I am running segmentation on the Maxilla, Mandible, and cranial base and select them in the options.

I click select “separated + merged” for generated files
-click check box for “generate surface file”
-I have been keeping my GPU usage set to 1 and I don’t touch any other setting
-then i click “run prediction”

the time at the bottom left will run and then reach a certain point and stop.
I notice usually the first bar “scans ready for segmentation 0/1” gets 100% completed by my computer freezes before any segmentations are done.

I am using a MacBook Pro 2020, running on MacOS Monterey

In this case if you see the bottom left: Time is stuck at 75.01 seconds. I’ve tried to leave the program on for awhile but i never see it advance. If you have any tips/tricks on what you do differently I’d really appreciate any help!

Hello Jess,

Ah Did you set the direction of where to save the file? For my case the segmentation does not appear in slicer but it was save in the directory location that I intended to save it. After the time keep running and stop since the process was already finished. The file will automatically save in the directory file you choose. And you can drag and drop it in slicer to see whether it is the segmentation you want or not.

I actually face the same problem when I first started it.

Hi Thank you for getting back to me. I have checked and I do see the new folder created in the directory after I hit “run prediction” but no file is loaded in the file. I will try to keep the program running overnight tonight to see if there is a change. Did you notice that the file would appear in that folder even if the Slicer program appeared to be frozen?

Thank you for your help! I am hoping that I can get AMASSS to work for me

After the the process complete, the file will be there in that file. I think you did the right process. I am sure it will work. and after many try and error you will understand how it work.

I tried again but didn’t see the file but I will keep trying different settings. Thank you for all of your help! Could I ask if you are using a desktop computer or laptop? I’m not sure if that matters or not

Oh I am using MSI laptop. I also experience a few time of the program not running well because I am trying to run the DICOM file, But after that it work as normal. Follow the video tutorial and give yourself time. Keep trying after a ew trial you will figure it out.

But for me the AMASSS is not that accurate compare to normal segments. May I know what you intended to do with that segmentation?

Base on my experiences if the 2 points that I circled keep running until it reach 100% and all the 3/3 segments are showing. Then the “Cancel prediction” turn into “complete” (I forget what word will appear). The the segmentation you want will appear in the directory location you want it to be stored.

Ok thank you for your insights!

Hello, did you solve your problem? I’m having exactly same issue. I tried different kinds of versions but all of them get me quite similar results which is stopping time after completing bar with scans ready for segmentation.

No unfortunately I never got it to work for me. I’m still trouble shooting.