Problem with Dynamic Modeler Curve Cut

Dear all,

I have encountered a problem while using the Dynamic Modeler (curve cut) .

My workflow is as follows:

  1. Import a DICOM-RT Structure with the corresponding CT data set;
  2. Export the DICOM-RT Structure to a obj file (since the DICOM_RT Structure cannot be use as an input nodes in Dynamic Model);
  3. Import the obj file created in step 2;
  4. Generate a Closed Curve on the model’s surface;
  5. (Follow the tutorial workflow in this Dynamic Modeler tutorial video;

However, after this workflow, I cannot get the result like the result in the video. The new clipped file is always invisible. I guess these four screenshots are self explanatory.

The expected result:

The actual result:

Should you need more information or screenshorts, please inform me.
Any help from your side will be much appreciated!


There is no need for file export and import. Instead, you can go to Data module, right-click on the segmentation, and choose “Export visible segments to model node”.

You can go to Data module and click on the eye icon of the original (non-clipped surface) to hide it.

1 Like

Hi Andras,

many thanks for your help and support! I will try it under your guidance.

Have a nice weekend,

Hi Andras,

many thanks for your support!

This method works well!

However, this problem still exists. And I found that it was because the place of the Markups. Sometimes the ClippedRegion can be shown correctly, but if I move one of the Markups slightly, the ClippedRegion will becomes invisible again (please refer to the two screenshots below).

Do you know why this happens?

Many thanks in advance!

Similarly to most other complex computational geometry algorithms that operate on polygonal meshes, this tool is somewhat sensitive to the quality of the input mesh and curve. If processing fails then you can do the following:

  • improve input curve:
    • constrain the curve to the mesh: in Markups module/Curve settings, choose Curve type → Shortest distance on surface, Surface / Model node → the surface you wan to cut
    • resample the curve: in Markups module/Resample click Resample curve
  • improve mesh quality (subdivide mesh if the original, mesh resolution is too coarse; remesh cells of the mesh are ill-shaped, etc.)

@Sunderlandkyl do yo have any other suggestion?

1 Like

Dear Andras,

thank you so much for your help and support!