Problem with Elastix extension module

Hello, I have a problem with Elastix extension. I tried repeat simple registration case of Free Sample Data according to the instructions in You Tube video:
But something is wrong (see PrtScrn). Can anybody help me?
Thank you, Kuba.
University Hospital Hradec Kralove, Czech Republic.

Probably you need to have your data in directories with only ascii characters in the paths - sorry, the program is limited in this regard. Some internationalization is a work in progress, but we use a lot of libraries and not all the code handles non-ascii characters.

Hello Steve. I renamed the user´s account ( and everything work now.
Thank you, Kuba.
University Hospital Hradec Kralove, Czech Republic.

You can also try a recent Preview Release , as it uses Python3, which handles unicode strings somewhat differently (but at least upgrade to the latest Stable Release so that you can benefit from all the developments and fixes we implemented in the last 2 years).

Thank you Andras!
I use version 4.8.1, because extension manager (install extension) does not work in recent Stable Release 4.10.2 . I had also a problem with viewing DICOM files in version 4.10.2. In older version 4.8.1 everything is working.
I successfully repeated simple example in youtube video mentioned above. In the next step, I tried to use Elastix with my own data sets. I have MR T2W and CT (with radiotherapy structure set) of the head and neck of one patient. MR is my fixed volume and I need to deform and match my CT data. Both scans are shifted more than 20cm. So I decided to use Transform Module to pre-align and then I used Elastix. But I received a very bad result.
Where I made a mistake? (

I am a novice with 3D slicer. Sorry for maybe stupid question…

Thanks for the feedback about 4.10, very useful! The new extension manager is under construction, so that issue will be solved soon, but can you please tell us what kind of problems you had with DICOMs in 4.10?

About the registration, I don’t think you need pre-alignment. Also not sure that Elastix considers transforms that are not hardened, but hardening comes with some data loss.

1 Like

I can confirm that Elastix module only considers hardened transforms. There may be a slight image quality degradation due to resampling only in the case when warping transform was applied on the volume (no resampling is performed when linear transform is applied, so image quality is not impacted then).

1 Like

What operating system do you use? What do you mean by “does not work”? The extension manager does not appear? Does the application hang or crash? You can install extensions but they do not appear in the module list?

When I try load Dicom data I obtain Error message (see PrtScrn) and after that, I can see image only in small zoom area but not in red, yellow and green windows (also PrtScrn).

I use Win7 Professional. I mean that when I click on Install extension I can see only the empty black window.

What exactly hardened transform means? Why my deformable registration mentioned above gives me bat results?

The error message about DICOM SRO should not prevent loading anything. Are your data loaded fine after this?

I developed the SRO import/export plugin, so I’d appreciate if you send me your data (anonymized if possible) that brings out this error. Thank you!

As I wrote above, after this error message data are probably loaded, but I can not see images in red, yellow and green window. I can see image only in small square (zoom) in the left bottom corner of the screen. (see in PrtScrn). It is not problem of my data I tried it with free sample included in slicer with the same result.

If the data is loaded, then there should be no problem with displaying it. Check it out in the Volumes module. See the dimensions and scalar range of the volume and see if it’s reasonable.

Thank you, but I’d like to fix this issue if you’re willing to help me reproduce it.

I will check it again in my office tomorow and I will let you know.

I checked it again. I downloaded Sample Data (MRHead), opened Volume module and I can say that Dimensions are 256, 256, 112. The scalar range is 0 - 695. And again I can see image only in Data Probe (Show Zoomed Slice). How can I help you to identify where the problem is?

Thank you, Kuba.

Based on your latest screenshot it shows that you are using Slicer 4.10.2 stable but it shows that you installed the SlicerRT extension that was built with Slicer 4.11 nightly revision 28371. This is a problem. Did you manually install a nightly extension for Slicer 4.10.2?

Uninstall this extension and reinstall using the extension manager within Slicer 4.10.2 stable. Or download the extension zip that is built specifically for Slicer 4.10.2 and install manually.

I see what’s the problem now. Slicer-4.10 requires OpenGL version 3.2 to take advantage of new features in graphics cards. OpenGL 3.2 is supported on all computers that are manufactured in the last 5 years or so, but not on computers that are much older than that. I would recommend to upgrade your computer, not just because of Slicer but also because Windows 7 and 8 are very insecure to use.

Thank you Andras,
you are right. I installed Slicer 4.10.2 on the newest computer in our department (Win 10, 8GB RAM, 2,8GHz) and the problem is solved.