Problems installing pyradiomics via pip install


I want to batch process a number radiomic extractions. Since I believe there is no way to do that through 3D Slicer, I tried to install pyradiomics. I’ve tried with the suggested python-versions as well as newer, but get different error messages depending on the python-version.

" Getting requirements to build wheel … error
error: subprocess-exited-with-error" with the latest python version 3.12.

Any suggestions what I’m doing wrong?

Best regards

I would suggest just using the version of python that comes with slicer and the pyradiomics you get with SlicerRadiomics.

Thank you for the suggestion,

However, I’m having a hard time localizing the pyradiomics python file. I searched for “” or “” in my slicer folder, and didn’t find the files, which made it hard to use the command line to batch process my files. Are they installed in other locations?

Best regards


If you install the SlicerRadiomics extension you get the python package too.

On linux everything is in:


In the Slicer python console you can do import radiomics

Now I feel rather stupid. Have been using 3D Slicer for quite some time, but never really noticed the little icon with two snakes up in the toolbar…

Thank you.

Best regards