Problems with SkyscanRecomimport

Dear all,
I am trying to reconstruct the CT images, but it is not working.
I used Skyscan 1272 to achieve the CT data and they are in tiff format.
When I plugged in the tiff data into Volume Rendering or Image Stack, only the Axial data showed up properly, but rest of the reconstructed images were not what it should be.

So the next thing I tried was using the log data.
However, this also did work, showing the error messages such as below

Any advice will be much appreciated.

You have loaded a sinogram - a series of projection images. You need to use a toolkit such as RTK to create a 3D volume from it.

If you want to implement your complete workflow in Slicer then you can implement a Python script or module that launches RTK from Slicer.

Tutorial for SkyscanReconImport is here:

You have to provide a the _rec.log file as the input. From the screenshot above either you are not passing the correct log file, or the file doesn’t have the fields our module expects.

Did you reconstruct these shadow image (sinograms) with the Nrecon and obtain the cross-sectional slices? That’s what SkyscanReconImport works with. If you did and still have issues, please send us a copy of the log file along with a few of the reconstructed slices…


Thank you guys all for your help!
Sadly, I couldn’t figure out how to use the RTK but I was able to ask the operator for the reconstructed file of the CT images!
After receiving new file, I realized why the SkyscanReconImport did not worked!
I been using _.log file instead of the _rec.log file!
Now my problems are solved.
Once again, thanks to you guys and I wish you have a great day!

1 Like