Radiomics module crashes anytime I use a "Theta parameter map"

Hi,
good morning to everyone and sorry if my question has a solution in thread I have not found.

My problem is simple:
Eveytime I’m trying to evaluate radionics features using a diffusion map obtained by the DWModeling, using the model “Gamma distribution”, “Theta parameter map”, 3D Slicer crash.

I have tried many times, closing all other maps, loading just the data necessary for this analysis, but I’m always encountering the same problem.

This sounds very strange because Radiomics module has been able to evaluate features with any diffusion model I’ve used, just with this map it crashes.

My operating system tell me that there is a memory problem.
It’s very strange because the “Input Label Map” is always the same, and it comprise just a few points.

This is my version: 4.9.0-2018-01-14 r26833
My computer is Apple Mac Book Pro.

Thank you very much for your support and thank you for developing this amazing software

What is the scalar range that you see in the theta map? You can find it in the Volumes module as shown below. It might be that the output map contains NaN pixels which may not be handled properly.

image

The range is very large.

Maybe this can be the problem?

There is a way to insert a threshold?

Thanks

The range in my screenshot is the range for a different image. What is the reported range for your example? Can you share the theta map?

This is my map.
The range in the screenshot I have sent before should be right.

Hi,
Did you receive my email with data?

I can send you again my image with the label-map (Diffusion map-label.nrrd) I use to extract features.

Thank you very much

Andrea

@Andrea_Barucci1 no, I did not receive any images or screenshots from you.

I have sent you two times…
Can I send using your private email or another method?

However yesterday I did some other data elaboration, and I discovered that the same crash problem I can encounter with other map, e.g. DDC map.

My opinion that the problem can come from the memory of my computer.

What do you think?

On Monday I will try these elaborations with a different computer.

Let me know what you think and how I can send you the data.

Thank you very much for your support

Best

Andrea

Andrea Barucci

Dear Andrey,

I have tried to send you .nrrd files but it’s impossible.
I just insert here two screenshot of maps informations using the Volume Module.

K map in this case doesn’t crash when I use Radiomics module.
However when I try to analyse DDC map using Radiomics, 3DSlicer crashes.

Do you think that this problem can be due to the range of the map?
Or is a problem of my hardware (not enough memory)?

Using the Radiomics Module I’m encountering this problem many times, often with DDC map, Theta parameter map, etc.
All these maps have been evaluated using the DWI module.

Thank you very much for your help

DDC_map_Radiomics_CrashK_map_Radiomics_NOT_Crash

@Andrea_Barucci1, PyRadiomics (which is the back end of the SlicerRadiomics extension) supports resegmentation. If so specified, it will exclude voxels outside a given range. The extension does not have GUI elements to set this though, so you’ll have to make a parameter file and supply that (if that is not possible on you version of slicer, you’ll need to install the latest stable release and re-install the SlicerRadiomics extension).
See here (look for parameter resegmentRange) for the setting of resegmentation and here for information on making a parameter file.

Alternatively, what you can also try is to extract features using the stand-alone version of PyRadiomics. If there is an error in PyRadiomics, it will also be displayed. See here for instructions on how to install the stand-alone version of PyRadiomics and here on how to use it.

You probably replied to the forum posts by email with attachments, and I don’t know if that works. The most reliable way to share sample datasets is to upload to Dropbox or similar, and include the link in the forum post.

Thank you very much for your kindness and help.

I will share here my dataset, just to let you check if you encounter the same problems in data analysis.

Dataset: https://drive.google.com/file/d/1P-5UKdr2YSlo3k5EX4nJkJRSdPhlxKxK/view?usp=sharing

Thank you very much

When I click the link I get the error below.

Make sure you do not have any patient information in your dataset before sharing.

image

Now the dataset should be available.

There are no patient information in the dataset shared.
The name of the folders are just “fictitious names” that I use to remember who is who.

Thank you very much

@Andrea_Barucci1 I downloaded your dataset, but I am unable to move forward, since I discovered other related issues, and I cannot install Radiomics extension in either stable or nightly release… I will look into that when I have the setup.

Thank you very much.

In the last week I have encountered the same problems.
Instead I’m using a Nightly version of January.

With the last versions of Slicer I’ve many troubles with all Slicer modules in general.
I don’t know why.

I was wondering that was a problem of my computer.

@Andrea_Barucci1, we created an issue on the PyRadiomics repository. I posted the cause and solution there.

1 Like

Thank you very much for your help.

I have to download a new version of the Radiomics module?

We also committed the fix to hopefully resolve the build issue for the Radiomics extension on mac. We will see tomorrow if that worked!