Remove intesection lines in specific 2D view

Hi all,

I posted a question last time but did not get solution, so I’m posting it again.

I created four 2D slice views looks like the video below.
Among these, I only want to display the intersection view in the axial window.

To achieve this, I tried changing the visibility to 0 or modifying the LinkedControl as shown below, but I observed that the intersection line reappeared when I moved the slice.

  1. sliceDisplayNode.SetIntersectingSlicesVisibility(0)

  2. sliceCompositeNode.SetLinkedControl(False)

Additionally, I performed SlabReconstruction on the leftmost panoramic view, but the line corresponding to the slab appeared, which interferes with the visualization.

Therefore, my questions are as follows:

  • How can I display the intersection line only in the axial view?

  • How can I remove the lines related to the slab?
    (When I enable slab reconstruction with sliceNode.SetSlabReconstructionEnabled(True), the line is generated, and I couldn’t find a way to turn it off.)

  • In addition, How can I change the thickness of the intersection line?
    (sliceDisplayNode.SetIntersectingSlicesLineThicknessMode(2) does not work.)

A post was merged into an existing topic: Show slice intersection line only in specific view