Saggital and Coronal view are distorted (stretched out)

Operating system:Microsoft Windows 10
Slicer version: 4.10.1
My micro-CT data in tif format was loaded into 3D Slicer,the axinal view display normally,but the coronal and saggital view was distored like a line.

I´ve changed the Image Spacing but I dont the threes correct numbers. What are correct values of the Image Spacing ? Or How I solve this distortion ?
The Image Spacing chosen by 3D Slicer :
The expected image :
MY micro CT datas :

1 Like

You need to find the correct image spacing for your Z dimension. Looks like data came from a microCT scanner. File is too large for my to download on my current connection, but maybe there is a text file or some sort of description of scan settings. Perhaps people who scanned it can tell you those…

1 Like

Thanks @muratmaga. The only informations that I have about how the microCT scanner was seted
are those two :

  1. Current = 74.000000
    Data Type = ushort
    Image Height = 1013
    Image Width = 992
    Images Taken = 995
    Pixel Size = 6.233620
    Voltage = 40.000000

  2. This report:

Report shows pixel resolution as 6.23 micrometer. I would try that for all axes

1 Like

muratmaga@ I tried do this, but Sagittal and Coronal images are completely black.

I understanded that If I reduce the number in third box of the Image Spacing the size of line that appears in the sagittal and coronal planes also decrease.

Image Spacing = 0.5mm

Image Spacing = 0.05mm

From your screenshots, you only have 1 tiff file loaded rather than a stack.

You can import the tiff stack as an image sequence in Fiji or ImageJ and save as NRRD–you can also set the Image Resolution before saving the NRRD, then import the NRRD into Slicer.

1 Like

Conversion to nrrd using Fiji is a good option for special image formats, but in general you can import a tiff stack directly into Slicer by unchecking “single file” option in “Add data” window. See details here.



I meant that all values in your Image Spacing setting should be 0.00624, as you appear to have scan that has isotropic voxel size. Once you set that up, use the little square icon on the slice view to adjust the zoom level for each view.

1 Like


Thankyou. I imported the tiff stack as an image sequence in ImageJ and saved as tiff because I didn´t find nrrd. Then when I imported in 3D Slicer, the three views appears correctly proportionally,but I am not sure, and the images appears much greater that it really is.
Image of 3D Slicer:

The real image: image

TIFF format cannot store slice spacing, and the volume does not look stretched out, so it means that scaling is incorrect on all axes now. You can fix it by setting known spacing value in Volumes module as written above.

Thank you very much! I have made your suggestion and the images now appear to be correct.
The problem solved:

1 Like


When I impoted my datas I checked if the "single file was unchecked and was.But even so I had the sam problem with sagital and coronal planes. I belive the suggestion of muratmaga solved my problem.
But whicht are special image formats?


Thankyou for your explication. But I don´t understand two things

  1. The format tiff is bad to import
  2. What you want sat say with " and the volume does not look stretched out"?. The image wasn’t distorced, the problem is just scale?

Tiff is not ‘bad’ per se, just not convenient for this kind of data.

Tiff format does not have a way to preserve the voxel spacing you manually entered. Therefore, every time you import that dataset, you will have to manually enter those spacing values. Because of this, and various other reasons, people prefer to convert their image sequences into a volumetric formats such as NRRD, Nifti (nii) and others.

Once you imported your data and corrected the voxel spacing, all you need to do is to save it as a NRRD file through Slicer’s save dialogbox. After that you can open it in Slicer without having to worry about these issues. Here is a list of file formats support by Slicer:


You can adjust the spacing in Fiji as well under Image --> Properties before exporting. For microCT tiffs, I have found that they load quite slowly into Slicer and that’s why I import to Fiji, set the resolution, and save as NRRD–the NRRD loads much faster into Slicer. But yes as @muratmaga mentioned too, even if you set the resolution in Slicer as you did above, you can just save the new NRRD with the correct resolution.


@tsehrhardt what version of the slicer are you using to import image stacks? It used to be slow, but in the last year or so, there is not much of a noticable speed difference between importing into Fiji or slicer for me. The only existing issue, if you import a non-tiff stack into Slicer, you need to run the vectortoscalar conversion.

1 Like

I am currently on Slicer 4.10.1. I haven’t tried importing tiffs in a while, since I automatically use Fiji. I’ll have to try and see if it’s better for me now.

For posterity, ImageStacks in SlicerMorph extension should be close to the performance you can get from FIJI importing an image sequence and saving it as NRRD.


Yes ImageStacks is much better than Fiji!

1 Like

2 posts were split to a new topic: CT image appears to be distorted