Sample Data Load Complete, Still Won't Appear

My sample data will download but it will not appear on the slices. I have restarted my slicer and laptop, still doesn’t work. Any tips?

1 Like

It is possible that the downloaded file is invalid. Can you try to delete the files in c:\Users\[YourUser]\AppData\Local\Temp\Slicer\RemoteIO and try again?


Hello Mr. Pinter,

I deleted the file and it still did not work. Any other ways to solve this issue? I tried to use this code to import the data but it gave an error. This is a part of my final code so do you know how to fix this?

import SampleData
sampleDataLogic = SampleData.SampleDataLogic()
masterVolumeNode = sampleDataLogic.downloadCTACardio()

1 Like

Try and delete the files in c:\Users\[YourUser]\AppData\Local\Temp\Slicer\RemoteIO and then run it again? It worked for me

1 Like

Thank you! Does anybody else have any other ideas as to how to solve this problem?

Please copy here the error messages from the application log.

<b>Requesting download</b> <i>CTA-cardio.nrrd</i> from
<i>Downloaded 6.1 MB (10% of 61.1 MB)...</i>
<i>Downloaded 12.2 MB (20% of 61.1 MB)...</i>
<i>Downloaded 18.3 MB (30% of 61.1 MB)...</i>
<i>Downloaded 24.4 MB (40% of 61.1 MB)...</i>
<i>Downloaded 30.5 MB (50% of 61.1 MB)...</i>
<i>Downloaded 36.6 MB (60% of 61.1 MB)...</i>
<i>Downloaded 42.8 MB (70% of 61.1 MB)...</i>
<i>Downloaded 48.9 MB (80% of 61.1 MB)...</i>
<i>Downloaded 55.0 MB (90% of 61.1 MB)...</i>
<i>Downloaded 61.1 MB (100% of 61.1 MB)...</i>
<b>Download finished</b>
<b>Requesting load</b> <i>CTACardio</i> from C:/Users/nandanlocal/AppData/Local/Temp/Slicer/RemoteIO/CTA-cardio.nrrd...
Traceback (most recent call last):
  File "<console>", line 1, in <module>
  File "C:/Program Files/Slicer 4.10.2/bin/../lib/Slicer-4.10/qt-scripted-modules/", line 596, in downloadCTACardio
    return self.downloadSample('CTACardio')
  File "C:/Program Files/Slicer 4.10.2/bin/../lib/Slicer-4.10/qt-scripted-modules/", line 574, in downloadSample
    return self.downloadSamples(sampleName)[0]
  File "C:/Program Files/Slicer 4.10.2/bin/../lib/Slicer-4.10/qt-scripted-modules/", line 582, in downloadSamples
    nodes = self.downloadFromSource(source)
  File "C:/Program Files/Slicer 4.10.2/bin/../lib/Slicer-4.10/qt-scripted-modules/", line 514, in downloadFromSource
    loadedNode = self.loadNode(filePath, nodeName, loadFileType, source.loadFileProperties)
  File "C:/Program Files/Slicer 4.10.2/bin/../lib/Slicer-4.10/qt-scripted-modules/", line 678, in loadNode
    success =, fileProperties, loadedNodes)
ValueError: Could not find matching overload for given arguments:
('VolumeFile', {'name': 'CTACardio', 'fileName': 'C:/Users/nandanlocal/AppData/Local/Temp/Slicer/RemoteIO/CTA-cardio.nrrd'}, (vtkCommonCorePython.vtkCollection)00000151368AA9A8)
 The following slots are available:
loadNodes(qSlicerIO::IOFileType fileType, qSlicerIO::IOProperties parameters, vtkCollection loadedNodes) -> bool
loadNodes(qSlicerIO::IOFileType fileType, qSlicerIO::IOProperties parameters) -> bool
loadNodes(qSlicerIO::IOFileType fileType, QVariantMap parameters, vtkCollection loadedNodes) -> bool
loadNodes(qSlicerIO::IOFileType fileType, QVariantMap parameters) -> bool

Please try with latest Slicer Preview Release.

1 Like

Hello Andras,

I just did that and it works now! Thank you very much!