Sandbox - Curved Planar Reformat module not installing?

Hi all, I’ve recently started to use 3D Slicer and was looking for a curved planar reformat tool to use with anatomical features. I noticed the module should be included in the Sandbox extension, but when I install it the only modules to load are Lights, Line Profile, and User Statistics. I tried with versions 28257 and 29081.

Since I’m new to this it’s completely possible the problem is user based. If there’s a way around this can I get some guidance please?



Curved Planar Reformat module appears for me correctly after installing latest Slicer version (revision 29081) and Sandbox extension and restarting the application. Try uninstalling and reinstalling the extension (wait for the “Restart” button to appear). If the you still don’t see the module then copy-paste the application log here (menu: Help / Report a bug).

Hi Andras, thanks for the advise! I installed rev 29117 and then the Sandbox extension. All good with the Curved Planar Reformat, but now I’ve got a problem with the program interface. Compared to the 4.10.2 all the icons are in the menu at the top are larger, and when I access the All Modules menu the list extends too far to the left. I actually can’t see the modules past the third column. Is there something in the program setup I could change to fix this?

Thanks again,


You may need to set application scaling settings. What operating system do you use? (the exact software version is displayed in menu: Help / Report a bug -> Operating system)

On Windows, scaling settings are available if you right-click on the Slicer application executable (at a location like this: c:\Users\(yourusername)\AppData\Local\NA-MIC\Slicer 4.11.0-2020-06-06\bin\SlicerApp-real.exe), go to “Compatibility” tab, click “Change high DPI settings” and try all setting combinations.

Nothing like local knowledge. :wink: Changing the scaling settings worked, thanks!

1 Like

Scaling should be OK with default settings? What exact operating system version do you use? Do you have a special display configuration (multiple displays, very high-resolution screen, system font size or application scaling settings changed form the defaults, etc.)?

I thought it would be too, or at least it is with version 4.10.2.

I’m running Windows / Personal / (Build 9200) - 64-bit, nothing exotic, just a small laptop with a 14" screen and default settings.

Windows Build 9200 is Windows 8! Do you actually have Windows 8 on that computer? That would explain it, as it is very old Windows version, which may not have screen scaling APIs that current Qt toolkit relies on.

Interesting considering I installed Win 10 version 2004 a few days ago. :thinking:

Then somehow your build number is not displayed correctly, since build 9200 is indeed Windows 8

Plot thickens, the old windows version is reported by 4.10.2 (sorry I must have looked at the wrong window previously). 4.11 has it right, just wondering why the stable version thinks I’m living in the past.

As long as the preview is showing the correct version, it is fine.