Segment Editor: Draw Tube

Hi,

I am having issues creating a segment using the “Draw Tube” widget on Slicer 4.10.1.
image

Once I mark the fudicials, why won’t the “Apply” button be enabled?
What instances would render the “Apply” button enabled?

Thanks!

You need to place at least 3 fiducials for the apply button to become enabled for effects like “Draw tube” and “Surface cut”.

1 Like

Ahhh that did the trick. Thanks.

Hi,
But in my software(4.11.0), the button of "place a markup point and delete last added markup point in Fiducial Placement is grey and can not be activated, what’s the reason about this?
Thanks,
Xie

Have you added a segment? Do you have a master volume selected?

Hi Csaba Pinter,
I have created a new segment and set the master volume, but the button of “place a markup point and delete last added markup point” in Fiducial Placement was still gray.
Thanks,
Xie

I’ve just checked and it works well on Windows using both 4.10.2 and recent 4.11.x.

Please use latest stable version (currently 4.10.2) or later. Make sure to install “Markups to model” extension when offered (during installation of SegmentEditorExtraEffects extension). Is there any error in the application log?

Hi Lassoan,
After I delete the software and download the latest stable version again, the “Draw Tube” work well.
Thanks,
Dr.Xie

1 Like

Hey guys,
why this decision to require the user to mark 3 points? Doesn’t that mean I basically cannot draw a straight tube?

Have you thought about linking the undo/redo buttons under the fiducial gui to the fiducial placement, so that one can undo those?

Best,
Jens

There is no such limitation anymore. You can specify a straight line using 2 points.

If you use Slicer-4.10.2 then you need to update (or uninstall and reinstall) SegmentEditorExtraEffects extension. Or, you can install a recent Slicer Preview Release.

1 Like

@lassoan 3 points is still required to be able to press “Apply” for the Draw Tube effect and Surface Cut. I guess it could be changed for Draw Tube to support >= 2 points, but doesn’t make sense for Surface Cut.

Good point, “Apply” button was indeed disabled for 2 points. I’ve updated the extension now. Tomorrow’s version should allow you to draw a line using 2 points.