Segmentation Fast Marching effect does not work

Operating system: Mac OS 10.15.7
Slicer version:4.11.20210226 r29738 / 7a593c8
Expected behavior: Segmentation effect fast marching grow a region in contrasted aorta
Actual behavior: does nothing at all
I have done everything I’m suppose to do (add new segment, select it, paint in some spots inside the contrasted aorta, 1% maximum volume, iizialyse). Nothing happens, it remains the same or even erase the painted spots. Please help me, I don’t know how to do it. I have tried even this Thresold effect, but it’s the same, t doesn’t even seems to be a precess inside the computer when I clic Inizialise button. Thanks.

Can you paint in the aorta using the Paint effect? If not then make sure that:

  • segment and the segmentation are visible in the current view
  • “Masking” settings are correct (you can set them to defaults: editable area → everywhere, editable intensity range → turned off, modify other segments → overwrite all)
  • segmentation bounds are chosen correctly (see here)

If none of these helps then you could share the scene file with us (save your scene as a .mrb file, upload to dropbox/onedrive/etc. and post the link here) and we can investigate. Make sure no patient information is included.

Maybe this link helps - including how to segment the aorta in 30 s:

If you get this working, “Fast Marching” should be possible too.

I have the exact same problem. Operating system Windows 11 Pro, Slicer version 4.11.20210226 r29738 / 7a593c8

I am trying to follow the 3D Slicer segmentation recipe ‘Aorta segmentation (fast, using Fast marching)’, so I loaded the sample data CTACardio and followed the steps in the recipe by creating a new segment, then painting a few strokes inside the aorta. Then I select the Fast Marching effect, set the Maximum Volume to 1%, and press Initialize. For a few seconds ‘Running Fast Marching’ is visible in the lower left corner of the window. After that, the few strokes I painted in the aorta have slightly changed position and size/shape, but the Segment Volume slider stays greyed out, so I cannot change the volume of the segmentation as should be possible according to the recipe.

Have you a compelling need for ‘Fast marching’ ?

If not, you can try ‘Local threshold’ and ‘Flood filling’. Experiment with all options, segmenting an aorta is usually a simple task.

These are the most common confusions. Make sure that painting works first as @lassoan suggests.

Thank you for your replies!
@chir.set, I do not need to use fast marching per se, I was just getting familiar with the different ways to segment vessels with 3D slicer and following the tutorials/recipes. @mikebind, I can paint in the aorta and all the settings are as @lassoan suggests.

The problem seems to be solved by installing the preview release of Slicer, 4.13.0. Now the Fast Marching algorithm works as described in the recipe with the sample data set CTACardio.