Segmentation is clipped when exporting to RTstruct

stl
segmentation
dicom

#1

Hi,
I am importing an STL file (couch, in green) as segmentation on top of a DICOM CT (which has its own contour, in gray). In the attached picture you see the three central CT slices, the CT contour (gray) and the STL file (green).

I would like to export the segmentation as a RTSTRUCT contour on top of this CT, even if it is outside the field of view of the CT. Thus, in the data hierarchy, I move the segmentation into the DICOM Study and then export.

That works well so far, with the exception that the green STL contour is clipped along the slice axis (not on the other axes). See on the second image, obtained when I reimport in Slicer the exported dicom.

I would like to ask for a feature (check-box advanced option) where one could enable saving contours outside of the first/last slice. I guess this should be possible as the RTSTRUCT contours are specified as 3D coordinates. Thus, one could add the out of range contours by adding them recursively to the last CT slice but using a different z coordinate.

Do you think this is doable? Thanks in advance.
Thanks.


(Andras Lasso) #2

You can expand the CT volume using Crop volume module to include the complete segmentation (you may need to enable interpolation). Then use this expanded CT volume for DICOM export.


#3

It works! Thanks for the fast reply.

It adds however some storage overhead of the new CT slices (514kB per slice). As these are all with a fixed HU zero-value, do you know if there is an option in Slicer to compress these .dcm files when exporting?


(Andras Lasso) #4

Slicer does not support compressed DICOM export. It is not a common need, as usually compatibility is more important than some saved disk space or network bandwidth. You can of course zip the files and save on storage. You may be able to apply compression on the image data inside the DICOM file by using DCMTK toolkit.