'SegmentEditorEffect' object has no attribute 'segmentMarkupNode'

I’m trying to use Nvidia Ai using the sample script (https://gist.github.com/lassoan/ef30bc27a22a648ead7f82243f5cc7d5)
First I got an internal error for the study which is running successfully in the editor but not with the script, so I updated the slicer to the latest nightly build, then I got this error.

slicer.util.updateMarkupsControlPointsFromArray(effect.self().segmentMarkupNode, inputPoints)

AttributeError: 'SegmentEditorEffect' object has no attribute 'segmentMarkupNode'

I tried to uninstall and install the MarkupTomodel extension.
any changes in SegmentEditorEffect class for the latest nightly build??

For some reason, NVidia developers renamed segmentMarkupNode to annotationFiducialNode. Make the change in the script accordingly and let me know if it fixed the issue.

1 Like

Thanks, that error is gone now.
But that unexpected error window came up, :frowning:
let me share the log file and traceback window error message with you,

the same study works in the editor though.

hello @lassoan,

Am i missing somthing here? :frowning:
i’m trying but not geting the result , same error message all time.

NVidia develepers changed the module so that input points are now cleared when a model is selected the first time, so now you need to select the model before you set the points. I’ve updated the example gist accordingly.