SimpleFilters (BinaryThinningImageFilter) not working in latest MacOS build?

I’m trying to run BinaryThinningImageFilter on the CTACardio dataset. (Tried it on my own dataset and it didn’t work either, so I figured I’d try a sample dataset.)

  1. Load CTACardio
  2. Select “Simple Filters”
  3. Select “BinaryThinningImageFilter”
  4. Select CTACardio as input
  5. Select “Create new volume” as output
  6. Hit “Apply”

Filter never returns. Stays at zero percent, also UI is fully functional (step through slices, etc). No errors on console, only output is:

myFilter = BinaryThinningImageFilter()

I saw some posts a few days back on issues with SimpleFilters- is this related?



Latest Slicer Preview Release should work. Progress reporting broke in the ITK release candidate that we are using, so it may look like ITK is not working, but most probably it does, you just need to wait. The new ITK release candidate that has just been tagged is supposed to contain a fix, so the problem is expected to be solved soon.

Try latest Slicer Preview Release, other filters, and on smaller data and let us know if they work.

OK, other filters work fine. I know I’ve run this before, specifically for this workflow (below), but I feel like I’m doing something wrong… I will let it run but I’m pretty sure it did not take this long the last time I did this.


I have observed that the main Progress Reporting PR ( still hasn’t been merged and that the recently tagged ITK 5.1rc02 does not contain any of the commits from that PR. Maybe it will make it into ITK 5.1rc03 in a couple weeks.

1 Like

Is the lack of progress reporting back to slicer the issue?

I really feel like I’m doing something wrong.

I have a segment that I’ve converted to a label map. I try to run this through the Binary Image Thinning Filter, creating a new label map volume. It never returns. I’ve run other filters and they seem to work.

Should this work?

Also, for what it’s worth, I tried this on 4.10.2 and it did the same thing. I know I’ve done this before and it worked, because I opened the old scene file I had where it did work.