Slicer automated dental tools AMASSS


Any one has got the Slicer automated dental tools to work ?

I am using the Slicer 5.5.0-2023-09-13 r32175 / 23bf4eb on Garuda Linux (6.4.12-zen1-1-zen (64-bit))

I have downloaded test scans and latest models and when i run the prediction it stops after few seconds
This is the message i get,

========= ERROR =========

CLI execution failed:

In the future np.bool will be defined as the corresponding NumPy scalar.
In the future np.bool will be defined as the corresponding NumPy scalar.
Traceback (most recent call last):
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/”, line 99, in
import itk
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/lib/Python/lib/python3.9/site-packages/itk/”, line 28, in
from import *
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/lib/Python/lib/python3.9/site-packages/itk/support/”, line 35, in
import as itkt
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/lib/Python/lib/python3.9/site-packages/itk/support/”, line 175, in
) = itkCType.initialize_c_types_once()
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/lib/Python/lib/python3.9/site-packages/itk/support/”, line 140, in initialize_c_types_once
_B: “itkCType” = itkCType(“bool”, “B”, np.bool)
File “/home/manjula/Documents/Software/Slicer-5.5.0-2023-09-13-linux-amd64/lib/Python/lib/python3.9/site-packages/numpy/”, line 313, in getattr
raise AttributeError(former_attrs[attr])
AttributeError: module ‘numpy’ has no attribute ‘bool’.
np.bool was a deprecated alias for the builtin bool. To avoid this error in existing code, use bool by itself. Doing this will not modify any behavior and is safe. If you specifically wanted the numpy scalar type, use np.bool_ here.
The aliases was originally deprecated in NumPy 1.20; for more details and guidance see the original release note at:
NumPy 1.20.0 Release Notes — NumPy v2.0.dev0 Manual

Thank you

Ok Figure out the issue with the Slicer automated dental tools.

It works only on the stable release. I was trying it on the latest versions.

Can you explain more your context (how did you make it work) and share results?
I’be interested on trying this myself

Thanks a lot,

1 Like

Hi Mauro,

Well, it works perfectly but only on the Slicer stable version ( I tried the ALI and AMASSS). I tried installing the Python libraries manually with the preview release. I haven’t tried the rest.

How it works?

  1. Fresh download of the 3D Slicer stable version and extract.
  2. Install only the SlicerAutomatedDentalTools extension


It works well with the test data and other CBCT (I tried)

With test data

with a another CBCT

AMASSS ( It works well with the test data and I did not have time to test other CBCTs)

I tried SlicerDentalModelSeg this way and did not work.
The output I get from SlicerDentalModelSeg. Even when I install the missing packages pandas,tqdm etc. using them using “pip_install(“pandas”)” it finally ends with error messages. this is the first error.

However when I install other extensions (even if I uninstall and reinstall only the Dental tools this does not work and these are the outputs I get.

1 Like