Slicer Elastix Error Code: 4294967294

Dear All,

I started work on SlicerSegmentationRecipes/VesselSegmentationBySubtraction at master · lassoan/SlicerSegmentationRecipes · GitHub
I tried to run the Elastix module, but I keep getting the same error :
Error: Command ‘elastix’ returned non-zero exit status 4294967294.
It occurs in both the Stable(5.0.3) and the Preview Release.
Do you have any solution for it?

Thank You in advance,

Oliver Faris Halaseh

Dear All,

I got the same error message: “Command ‘elastix’ returned non-zero exit status 4294967294.”
I am using Windows 10 and Slicer version 5.2.2.

This is the error message from the Python window

[FD] ERROR: the output directory "C:\Users\Palkovics Dániel\AppData\Local\Temp\Slicer\Elastix\20230420_172652_127\result-transform" does not exist.
[FD] You are responsible for creating it.
Traceback (most recent call last):
File “C:/Slice/Slicer 5.2.2/NA-MIC/Extensions-31382/SlicerElastix/lib/Slicer-5.2/qt-scripted-modules/”, line 341, in onApplyButton
self.logic.registerVolumes(self.fixedVolumeSelector.currentNode(), self.movingVolumeSelector.currentNode(),
File “C:/Slice/Slicer 5.2.2/NA-MIC/Extensions-31382/SlicerElastix/lib/Slicer-5.2/qt-scripted-modules/”, line 635, in registerVolumes
File “C:/Slice/Slicer 5.2.2/NA-MIC/Extensions-31382/SlicerElastix/lib/Slicer-5.2/qt-scripted-modules/”, line 557, in logProcessOutput
raise subprocess.CalledProcessError(return_code, “elastix”)
subprocess.CalledProcessError: Command ‘elastix’ returned non-zero exit status 4294967294.

Is there a solution to this on Windows?

Thank you very much


Can you check if installing Slicer in a folder that only contains ASCII characters (no accented characters such as á) makes any difference?
Does registration work between MRBrainTumor1 and MRBrainTumor2 sample data sets?