Slicer quits when I load TIFF

Operating system: Windows 10 Enterprise
Slicer version: 5.0.3
I’ve been trying to load a TIFF file into Slicer but it keeps quitting whenever I try. I’ve tried using the “Add Data” button as well as loading through ImageStacks in SlicerMorph. When I try loading the TIFF file with the “Add Data” button, I click “Choose File(s) to Add”, then I check the “Show Options” button and I uncheck “Single File”. However, this is still not working and the program quits before the image can load in the viewing module. I’ve tried uninstalling and reinstalling Slicer but to no avail. Is there any advice for what else I can do?

Below is the log file content for when I try to load it:
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Session start time …: 2022-10-10 10:37:02
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Slicer version …: 5.0.3 (revision 30893 / 7ea0f43) win-amd64 - installed release
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Operating system …: Windows / Professional / (Build 19042, Code Page 65001) - 64-bit
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Memory …: 16106 MB physical, 22506 MB virtual
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - CPU …: GenuineIntel , 8 cores, 8 logical processors
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - VTK configuration …: OpenGL2 rendering, TBB threading
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Qt configuration …: version 5.15.2, with SSL, requested OpenGL 3.2 (compatibility profile)
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Internationalization …: disabled, language=
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Developer mode …: disabled
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Application path …: C:/Users/rtlim/AppData/Local/NA-MIC/Slicer 5.0.3/bin
[DEBUG][Qt] 10.10.2022 10:37:02 (unknown:0) - Additional module paths …: NA-MIC/Extensions-30893/CleverSeg/lib/Slicer-5.0/qt-loadable-modules, NA-MIC/Extensions-30893/CleverSeg/lib/Slicer-5.0/qt-scripted-modules, NA-MIC/Extensions-30893/SegmentEditorExtraEffects/lib/Slicer-5.0/qt-loadable-modules, NA-MIC/Extensions-30893/SegmentEditorExtraEffects/lib/Slicer-5.0/qt-scripted-modules, NA-MIC/Extensions-30893/SlicerMorph/lib/Slicer-5.0/qt-scripted-modules, NA-MIC/Extensions-30893/MarkupsToModel/lib/Slicer-5.0/qt-loadable-modules
[WARNING][Qt] 10.10.2022 10:37:03 (unknown:0) - libpng warning: iCCP: profile ‘ICC Profile’: ‘CMYK’: invalid ICC profile color space
[WARNING][Qt] 10.10.2022 10:37:04 (unknown:0) - libpng warning: iCCP: known incorrect sRGB profile
[DEBUG][Python] 10.10.2022 10:37:04 [Python] (C:\Users\rtlim\AppData\Local\NA-MIC\Slicer 5.0.3\lib\Slicer-5.0\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: Annotations
[DEBUG][Python] 10.10.2022 10:37:05 [Python] (C:\Users\rtlim\AppData\Local\NA-MIC\Slicer 5.0.3\lib\Slicer-5.0\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Python] 10.10.2022 10:37:05 [Python] (C:\Users\rtlim\AppData\Local\NA-MIC\Slicer 5.0.3\lib\Slicer-5.0\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: SegmentStatistics
[DEBUG][Python] 10.10.2022 10:37:06 [Python] (C:\Users\rtlim\AppData\Local\NA-MIC\Slicer 5.0.3\lib\Slicer-5.0\qt-scripted-modules\SubjectHierarchyPlugins\ - Scripted subject hierarchy plugin registered: FormatMarkups
[DEBUG][Qt] 10.10.2022 10:37:05 (unknown:0) - Switch to module: “Welcome”

People use tiff in many different ways and probably this data uses some convention Slicer’s not compatible with. If the tiff is a 3D volume you can probably convert it to nrrd with something like imagej.

Is there any way I could still load it in Slicer or convert it in Slicer? I have a ton of images that have already been saved as tiff files and it would be a big pain to have to convert all of them.

If both ImageStacks and Data module fails, there is likely something different about the data. If you can share one dataset, we can try to see what the issue might be. Otherwise, it is hard to guess what the cause might be.

I couldn’t upload the tiff file and I’m not quite sure how else to put it in the forum, but this link should hopefully allow you to download the file. Thanks!

You have a multiframe tiff file, where each slice is different in size. That’s not the type of datasets 3D Slicer is designed for. Slicer is expecting a sequence of images with exact dimensions in each slice, and when stacked it constitutes a 3D volume of the structure

Given that this is a histology dataset, and not in 3D in nature (all I saw was a single slide), I don’t think 3D Slicer is not going to be very useful to you. probably ImageJ/FiJI would be better. What do you need the Slicer to do on this data?

Ah I see. I’m using Slicer to contour certain cells in these images. I’ve tried ImageJ before but the plugins for contouring haven’t worked very well. I’ll look into writing a script to convert the TIFF files to PNG so I don’t have to do it manually then. Thanks for all of your help.

You might want to investigate the open-source package QuPath to handle pyramidal TIFF files. QuPath is designed specifically for this type of histology imagery and it allow for annotations to be created through the interface. It can be downloaded here: