SlicerMorph failed to load DICOM

Operating system: Win10
Slicer version: 1.5
Expected behavior: Load DICOM images
Actual behavior: SlicerMorph crashed

Hello, I am new to SlicerMorph. I followed the tutorial and tried to load TorsoCT into SlicerMorph1-5. After importing the data, when I click “Examine” or “Load”, the software carshes. The message before the software automatically exits is as below:

I noted that suggests that “See if the SlicerDcm2nii extension will convert your images” . I am not sure if I am missiing the Dcm2nii extension. I tried to install SlicerDcm2nii extension in Extension Manager but I did not find any plugin related to Dcm2nii. BTW, the sample DICOM file from the link above could not be successfully loaded either.

I am confused how I can load DICOM images into my data. I am using laptop with a RAM of 16 GB.

Please try with the very latest Slicer Preview Release (that you download today) and let us know if it works well.

DCM2NIIX plugin sometimes causes a crash. Disable the plugin as shown here:
then re-try the import

Disabling DCM2NIIX solved the issue. Thank you.

1 Like

The crash is due to this known issue:

@Sam_Horvath is this supposed to be fixed in latest Slicer Preview Release?

This might have been fixed in the nightly, but we maintain a prepackaged version of SlicerMorph that is a few weeks stale, in case people cannot download it from the main Slicer site. That’s what @lv_xiao was using.

Yes, this should be fixed in the current Preview