Subject hierarchy changes after reloading .mrb

I have the same issue as described in Save subject hierarchy, only with volumes and not models.

  1. Load some data into Slicer
  2. Create a folder hierarchy
  3. Place the loaded volumes into the folders
  4. Save everything as an .mrb
  5. After reloading the .mrb the hierarchy has changed

This is the hierarchy that I am saving:

This is the hierarchy that I get after reloading the .mrb:

(the three US volumes change location)

MacOS. The same issue occurs with the stable release 4.11.20210226 and with several preview releases, including the latest 4.13.0, revision 30657, built 2022-02-26

Do you mean that you tried with the latest preview not only to load the scene but also to both save and load?

Yes, I tried saving and loading with the stable and preview versions.

I think I narrowed the problem a bit down:
Even though in the tree it looks like the parents are correctly assigned, they are not (this screenshot was of the state that was saved to an .mrb):

  • it says that the parent of the selected node is the scene, even though in the tree it’s parent is Pre-op imaging

It seems that dragging nodes does not update the subject hierarchy properly - or am I doing something wrong?

Thanks for the further investigation! So it seems that the problem is not on the save/load (i.e. MRML) side but the SH tree widget / model side.

How do you put these volumes under the folder? I know it’s a strange question, but maybe you do something extra we don’t. Also, not sure if you have access to another operating system (Windows or Linux) but if you could try the same thing it would help.

I don’t know why, but I cannot reproduce it anymore. If I manage to do it again I’ll describe what I’m doing exactly

Thanks for the update!