Volume rendering does not appear

Operating system: Windows
Slicer version:4.8.1
Expected behavior: GIve me a volume redering picture
Actual behavior: The program errors every time.

Do I have a to bad computer? HP Spectra Intel core i7 Geforce

See https://www.slicer.org/wiki/Documentation/4.8/SlicerApplication/HardwareConfiguration

Can you please give us the exact type of the GPU in that laptop and the amount of RAM it has?

Hi,
Geforce GTX 1080 and 8 gb RAM.

Definitely not too weak. Do you have issues with volume rendering?

Yes, the program stops working when I ask for a volume renderaing and only give me a White Picture. Sometimes it works, but then computer begins to work so hard and slowly.

Make sure GPU volume rendering is selected instead of the degfault CPU.

Please elaborate on this. What steps do you exactly take after starting Slicer? What does it mean “stops working” and “white picture”?

1 Like

PNG —the White Picture

I loading the dicom files- and the selects volume rendering in the menu. Klick on the Eye and the program Begins to work.
Slowly I mean that the I can not do anything els with the computer and if I move the mouse it Begins to thinking and the program dosent answer at all and I need to turn the program off with the activity manager.

Maybe the computer has two graphics card and the default working one is not the GTX?

Or maybe it is driver problem, what about other programs e.g 3D games do they work?

Is this a laptop? In any event, open the Nvidia control panel, navigate to the application settings to check the openGL rendering is done by the Geforce, not the integrated GPU…

No it is only one graphic card on this computer. And I work i programs like inspier, meshmixer, spaceclaim, blender, fusion 360 and that work with any problems.

Yes it is a laptop. Ok I will check on that.

As @cpinter suggested, make sure you are specifying the GPU rendering option. In the screenshot you posted it shows you are using “VTK CPU Ray Casting”. Change this to the GPU option.

2 Likes

In the screenshot you posted it shows you are using “VTK CPU Ray Casting”. Change this to the GPU option.

If nothing change, try the brain image from Slicer sample just to check if the problem is from Slicer not from the your image. If the brain image does not work try to remove slicer and re-install it. If it works, then maybe your image is very large, try to crop it to have a smaller image.

Hi, yes I try that but that gives me only some shadows in the 3D window, even if I select ct-bone on the preset.

Thanks, I will try that!

If CPU volume rendering does not work then it means there is a problem with your data and so GPU volume rendering is not expected to work either.

Please also try with latest nightly version of Slicer. It supports many more GPUs than Slicer-4.8.1.

1 Like

Hi

Can you also check the layout manager? What layout are you using?

Best

Ron

1 Like

Thanks, with the 3D slicer 4.9.0 all works fine so far.

1 Like