Why the Editor module is missing?

Operating system:Windows 7 X64
Slicer version:4.7.0
Expected behavior:Editor module
Actual behavior:Can’t find Editor module

无标题

无标题

as the image shows.I start 3D Slicer with debug mode using VS2013, but I can’t a module named ‘Editor’ which exists in 3D Slicer installation version.
I tried several version in Github and none of them has Editor module.What problem is it?

Thanks for sending the screenshot - in the terminal where you started Slicer there’s a python error saying that numpy cannot be imported and that’s why the Editor didn’t load.

You’ll need to go back and debug the build process to make numpy work since a lot of Slicer code depends on it. Building numpy, especially on windows, can be tricky, but if you describe your steps and post build logs hopefully someone here can help.

1 Like

Also, for developers who build Slicer, it is recommended to use the latest master version (now 4.9) but at the very minimum the latest stable (now 4.8).

1 Like

thanks for replying!
indeed I didn’t build numpy,because it makes building unsuccessful.
can you tell me where to find build logs?

On Windows the build logs are in [SuperbuildDir]\x64[Configuration] for example S4R\x64\Release

1 Like

thanks a lot,I’ve solved the problem:grinning:

Can you describe your solution in case somebody else has the same problem? Thanks!

when use CMake to generate the project, make sure the ‘Slicer_USE_NUMPY’ is selected.
无标题

the later compile in VS2013 maybe fail many times.I just compile over and over until it succeed…:joy:

If you need multiple attempts for the build succeed then most likely something interferes with the build process. It might be a too aggressive firewall disrupting network communication, antivirus software preventing/delaying file access, etc.

maybe you are right, I didn’t close the firewall.:grimacing: