3D slicer crashes when using VMTK extension's extract centerline in Slicer-5.2

Hi everyone,
when i try to compute centerline model using extractcenterline module, both by code or manually, the software crashes everytime. I’m using 4.13.0 version for windows (i tried 5.1 version for macOS bu the problem is the same). Is there any solutions or any alternative way to compute the centerline model?
(using 4.11 version the problem doesn’t show but i need to use the sandbox extension for other purposes but it is not available for this version, if i don’t get it wrong)

Thank you very much for your help!!

Could you share the input model or segmentation file? (upload to dropbox/onedrive/google drive and post here the link)

Thank you for your quick reply @lassoan! Here’s the link:


Inside the folder you can find both the vtk model and the segmentation model (i tried to compute the centerline with both).
Thank you again.

Hi @lassoan, i saw you tried to get access to the folder i put my models, i hope i allowed you to.

I wanted to ask an other question: is it possible to extract the tree curve from the network model instead of the centerline curve?
Thank you very much!

I’ve spent several hours investigating this issue. It is due to that if VMTK cannot find the path to an endpoint then it creates a line with a single-point. This was accepted in VTK-8.x but in VTK-9.x they changed the behavior so that it crashes the application. I’m working on a solution at both VTK and VMTK levels, but it is not easy, it’ll probably take a couple of days.

Until then, you can avoid the crash by moving the centerline endpoints to where the vessels are a bit thicker to ensure that they are accessible from the input point.

Ok, no problems.
I really appreciate it!

I’ve created an issue to track the resolution of this issue in VMTK’s bugtracker:

1 Like

Ok perfect, thank you.

while i wait for the solution, do you know if it would be possible to compute the tree curve centerline using the network model as input?

Hello! I am using slicer 5.2.2 and am still experiencing this issue. I am wondering if this issue should have been fixed in slicer 5.2.2, or do I need to update anything?

The problem is fixed in the current Slicer release. We will not provide further patch releases for Slicer-5.2, so if something does not work or you want to benefit from the lots of new features added since Slicer-5.2 then you need to upgrade to the current Slicer version.

I see. Thanks for the clarification!