Animator Module - Not exporting correctly

Hello! I’m running into a small problem with the Animator module. I’m trying to export a GIF of my model but when I select the directory destination and click export a window showing the GIF pops up, but the file itself doesn’t save anywhere on my computer. Any thoughts?

Thanks! Here’s a screenshot of my settings, maybe that’s where I went wrong…

I can’t replicate this on windows. Perhaps FFMPEG library didn’t install correctly? You may want to switch to Screen Capture module and see if ffmpeg library is installed (see below). Normally it should automatically offer to download and install for windows and mac in the first use.

After you created the animation, another option is to use the Screen Capture module to save just a series of images, which then you can turn into animated gif or mp4 using other software. See here for more information: Spr_2021/SlicerAnimator.md at main · SlicerMorph/Spr_2021 · GitHub

1 Like

Hello,

I think that’s it! Looks like the FFMPEG library isn’t installed (see below), I’m not sure what that is though so could you tell me how I can install it?

Normally, when you try to use the ScreenCapture module the first time and choose the output as mp4, it should normally offer to download and install it automatically.

In your screenshot above, change the output type from Image series to video.

. Can you try that?

I seem to be having a similar issue. When I take you advice and select video and then click capture and it prompts me to download ffmpeg. I click yes but the download fails. It does not offer an explanation as to why. Any suggestions?

You can look in the error log to see if there’s info on the ffmpeg install. Paste the info here and maybe it’s something we can fix. In any case, you can also install ffmpeg yourself (Download FFmpeg)

FFmpeg automatic installation is only available on Windows. For Linux and macOS you need to install it manually as described here.

It would be nice if you could implement automatic installation for macOS and send a pull request.

I’m having this very same issue. Following the steps now in hopes it works! With SlicerMorph, I animated moving through a thorax in the axial plane to reveal a pulmonary embolism. Animation looks great, appears to export, but is nowhere to be found in the assigned directory. I’m on a Mac Mini OS Monterey.

From this description it sounds like Animator exports the individual frames, but mp4 conversion fails. Is that correct? Are you sure you have the ffmpeg installed?

To verify, go to the ScreenCapture module, expand the Advanced options, and see if you have the ffmpeg executable pointing out to the right location. If not, you can I think you can here. But I am not a mac user, so I am not certain.

Hi Murat,

I was using the SlicerMorph module, not the Animator. I don’t have ffmpeg installed in the Animator module. I tried the Home Brew solution but it didn’t take. I’ll try the other link you shared. Thanks for trying to help me!

Slicermorph’s animator module uses screen capture module under the hood, which relies on the ffmpeg to do the conversion. Please download it and set it location in ScreenCapture and then try animator again.

Thank you. I will try these solutions when I return to the office. I appreciate the expert tips.

1 Like