AQ3DC not loaded and Q3DC with issues

I am trying to make angular measurements in models created after segmentation. For this, I was advised by a UMICH faculty member to use the AQ3DC. However, when I tried to open it, it said, “Module not loaded” (picture attached)

Can you please tell me how to download the module? I already have SlicerCMF reinstalled, and AQ3DC is still not showing up.

I was trying to use Q3DC instead, and I am having issues. Even though the list of markups is fine in the Markups module (picture attached Fiducial in Markups, Ex, LGo)

, some of them do not appear on Q3DC (Picture Fiducial missing: Ex LGo).
Some also appear twice in Q3DC (Picture attached, LCo markup appearing twice in the list)

I gave up using the measurement in the Markups module (Angle) since I have to position the points of the angle tool over the markups I have done using CBCT, which gives me imprecision measurements. Or is there a way to measure the angle with the markups opened in Slicer? (I got my markups using ALICBCT, then I would like to use them for the measuring part as well)
Please can you give some support?

Slicer 5.2.2