Blank display in standard views

Hi All,

I have a question regarding the display:
My computer does not show the orthogonal views with the latest nightly build versions (in the past week). I’ve tried with the sample datasets too, but I can only visualize the volume in the 3D viewer, but not in the normal views. I attach an image about it:

What would you recommend to correct?
Thanks for the help in advance!

Operating system: Windows 10, 64-bit
Slicer version: 4.13.0 -2020-11-02 (nightly build)

Welcome @Kalman,

Yes this is a know issue with the current Slicer preview. You should use the Current Slicer stable (4.11.20200930)

For more details see:

@lassoan Considering the number of reports of this on the forum, it might be best to “sticky” one of these posts to the top of the forum.

Thank you for the quick reply @jamesobutler!
First I’ve tried to search a topic for this issue, but as I see now, I used different terminology for searching.

If one looking for it, where could the latest ‘stable nightly-build version’ be downloaded? (as some newer segmentation tools can only accessed via the beta version, and I don’t have the installer file)

There is a new Stable release which is Slicer 4.11.20200930 which can be downloaded from The previous stable was Slicer 4.10.2 which was about 2 years old at the time of the new stable release and it was commonly advised to use the Slicer preview build for latest features. Now that advice has changed as the old Slicer preview has become the stable release of Slicer 4.11.20200930 and the current Slicer preview builds are unstable at the moment with various problems.

If you aren’t requiring Slicer updates since 2020-09-30, that new stable should work well for whatever tools you need.

Thank you very much!
Basically, I would need the Segment Editor’s ‘Wrap solidify’ tool and the ‘seed locality’ option of the ‘Grow from seeds’ effect (which was originally added only to the beta versions).

“Seed Locality” of the “Grow from seeds” effect is available in the stable Slicer-4.11.20200930

“Wrap solidify” is available after installing the “SurfaceWrapSolidify” extension from the Extensions Manager.

1 Like

Super! Thank you so much for the help @jamesobutler!

Good idea, it might help a bit. I’ve pinned a topic about this issue for a week (hopefully the issue will be resolved very soon).