Brain resample module issue

Hi everybody,
I found a weird behaviour to brains resample module on some PET/CT images I have.
Despite that PET/CT ScalarVolumesNodes are correctly displayed with correct informations as regards to the volume properties, the resample module raises an error:

Resample Image (BRAINS) standard output:

WARNING: neither warpTransform nor deformationVolume are defined, so warpTransform is set as identity.


Input Volume: C:/Users/l-ferrer/AppData/Local/Temp/Slicer/BCHGA_vtkMRMLScalarVolumeNodeC.nrrd

Reference Volume: C:/Users/l-ferrer/AppData/Local/Temp/Slicer/BCHGA_vtkMRMLScalarVolumeNodeB.nrrd

Output Volume: C:/Users/l-ferrer/AppData/Local/Temp/Slicer/BCHGA_vtkMRMLScalarVolumeNodeD.nrrd

Pixel Type: short

Interpolation: Linear

Background Value: 0

Warp By Transform: Identity


******* HERE *******D:\D\S\Slicer-0-build\BRAINSTools\BRAINSResample\BRAINSResample.cxx 475

itk::ExceptionObject (000000024AB5D870)

Location: “unknown”

File: D:\D\S\Slicer-0-build\ITK\Modules\IO\NRRD\src\itkNrrdImageIO.cxx

Line: 290

Description: itk::ERROR: NrrdImageIO(000001C04F65A7E0): ReadImageInformation: Error reading C:/Users/l-ferrer/AppData/Local/Temp/Slicer/BCHGA_vtkMRMLScalarVolumeNodeC.nrrd:

[nrrd] nrrdLoad: trouble reading “C:/Users/l-ferrer/AppData/Local/Temp/Slicer/BCHGA_vtkMRMLScalarVolumeNodeC.nrrd”

[nrrd] nrrdRead: trouble

[nrrd] _nrrdRead: trouble reading NRRD file

[nrrd] _nrrdFormatNRRD_read: trouble parsing space directions info |(0,97656250000000022,0,0) (0,0,97656250000000022,0) (0,0,2)|

[nrrd] _nrrdReadNrrdParse_space_directions: trouble getting space vector 1 of 3

[nrrd] _nrrdSpaceVectorParse: space dimension is 3, but seem to have 4 coefficients

Apparently, the PET/CT images I got haven’t 4 dimensions.
I tried with 4.11.20200629 r29190, slicer 4.11.20200930 r29402, slicer 4.1120210226 r29738
I also tried with different PET/CT images, same results

What is going wrong here ? That must be obvious but I am blind :confused:

Best regards

It looks like perhaps your machine’s locale has been set to something that prints decimal numbers using the comma character instead of the period character, so you get what looks like four comma separated numbers instead of three.

We had this problem before in Slicer and worked hard to make sure we always used the C LOCALE setting. I’m not sure how it crept back. Looks like this is your local build and maybe you changed something? Do regular Slicer binaries work?

Hi Steve,
nice shot. I will look at your suggestion.
A part from this issue, slicer seems to work correclty, but i didn’t thoroughfully search for such bug.
I am working on windows 10 that my company is taking care of. So, I am not sure i will have too much user rights to investigate. Il let you know here the results of my search.
thanks a lot.
Best regards

ok, your suggestion works. not sure i did the right way as i had to get into the windows registry :slight_smile:
best regards

Thanks for the report and glad you got things working :+1:

We hope to improve Slicer’s ability to be localized without being subject to this kind of issue with some of the older libraries.