Build arm 32 OpenSSL

When I try this step, error happens:

The error message indicates that the linker could not find some symbol (function, variable, etc.) when trying to build. But I dont know how to solve.
Best wishes,

Thanks for reporting. Something must have changed either with the mac build tools or something in OpenSSL source. I just re-ran that those commands on the same M2 mac where they worked before and now I get the same link error that you reported.

1 Like

Thanks so much. So I may not build Slicer on my mac now right?

Not without some extra work. You could investigate why this link error occurs by looking at any changes in OpenSSL since the time late last year when it worked vs the current version. Maybe checking out an older version would build correctly and if so maybe a patch could be developed to make a newer version work. It’s also possible that other people have noticed this issue and a fix is in the works (to know you would need to check the OpenSSL issue tracker). Since this failure is on a straightforward build of the library on a fairly popular OS I suspect it will eventually be fixed, but maybe you can help speed up the process with some research.

@Kening_Zhang Thanks for following up with additional details :pray: :100:

To help organize the effort, I just updated our “meta” issue adding links to issue reports and relevant discourse posts:

@Kening_Zhang @pieper

Could you add a summary of your latest finding regarding building OpenSSL on arm to the following issue report:

OK, I am working on it.