Building Slicer on El Capitan

Hi all,

I am trying to build Slicer on my Mac. Qt4 installer does not work on El Capitan. I have tried homebrew, but it only installs Qt5 now. I also tried compile Qt4 with the homebrew patch, still failed. Is there any other way to get Qt4 working?

I have successfully installed Qt4 with ‘brew install cartr/qt4/qt’ according to the post Thanks Christian!
While building Slicer, I run into the error “This platform’s pyconfig.h needs to define PY_FORMAT_LONG_LONG”. I tried configure python-cmake-buildsystem directly but still got the same error. Anyone has any idea why?


Hi xliu,

Would be great to share the error so that other building on MacOSX can help you.

Also since we build the official Slicer installer on a older MacOSX, we do not have a regularly tested solution.

As a side note, we are also actively working on finalizing the transition to Qt5.


I haven’t build Qt4 from scratch on mac osx for quite a while. It used to work but it’s entirely possible that it no longer works.

Following up on Jc’s note, it is possible to build mostly-working Slicer using the regular Qt5 download binaries.

@che85 also reported problems building on El Capitan that he could not resolve.

I don’t use El Capitan anymore. I am sure that you can specify the version of qt when using brew.

Ah, I forgot that El Capitan is no longer the latest one.

Does it work for you on Sierra Christian?

On Sierra it works.

Take a look at this post:

1 Like