Slicer build failed on Mac OS 10.12 Sierra

I’m having difficulty building Slicer on Sierra.
Operating system: OSX 10.12.5
Slicer: Newest nightly (Jun 6 2017)
Qt: cartr/qt4/qt
CMake: 3.8.0
Xcode: 8.3.2
I’ve tried CMAKE_BUILD_TYPE set to Debug and Release, CMAKE_OSX_DEPLOYMENT_TARGET set to 10.12 and 10.9. CMAKE_C_COMPILER is set to /usr/bin/clang and CMAKE_CXX_COMPILER is set to /usr/bin/clang++. QT_QMAKE_EXECUTABLE is set to /usr/local/bin/qmake, which has a symbolic link to qmake in the Cellar directory.

The build fails on the “python” target. Error output is:

PhaseScriptExecution CMake\ Rules /Users/michaelschumaker/Packages/Slicer-SuperBuild-Debug/
cd /Users/michaelschumaker/Packages/Slicer
/bin/sh -c /Users/michaelschumaker/Packages/Slicer-SuperBuild-Debug/

make: *** No rule to make target /Users/michaelschumaker/Packages/Slicer-SuperBuild-Debug/python-source-prefix/src/python-source-stamp/Release/python-source-done', needed by/Users/michaelschumaker/Packages/Slicer-SuperBuild-Debug/python-prefix/src/python-stamp/Release/python-configure’. Stop.
Command /bin/sh failed with exit code 2

What’s interesting is that, even when I set it to the Debug build type, the directories of python-source-done and python-configure in the error are still “Release”. Is there a mistake in the configuration script?

I’m just moving this to the top. Can anyone suggest a solution?

I don’t use a Mac, but on Windows Python is always built in Release mode (regardless of the application is built in debug or release).

Have you tried to build/get Qt as described on Slicer build instructions page?

Ok, thanks, I won’t worry about the build mode for the Python job. I was trying to identify any reason it might be the job that’s failing to build.
I installed cartr/qt4/qt before compiling Slicer. I had previously installed Qt5.8, though.

No, Slicer always builds python in Release (IIRC because of symbol export variations when built in debug).

For what it’s worth, I did a successful clean build of all python dependencies (rm python-* in the superbuild folder) in a Release build on Sierra within the past two weeks, and my folders look like this:

:r4nj inorton$ ls python-source-prefix/src/python-source-stamp/
download-python-source.cmake	python-source-configure		python-source-install		python-source-update
extract-python-source.cmake	python-source-done		python-source-mkdir		python-source-urlinfo.txt
python-source-build		python-source-download		python-source-patch		verify-python-source.cmake
1 Like

A post was split to a new topic: Slicer build error on MacOSX in DCMTK