Cannot import DICOM segmentation file

Operating system: Linux
Slicer version: Slicer-4.9.0-2018-09-26-linux-amd64
Expected behavior: Load segmentation file without error, and display it
Actual behavior: After loading all the slices without error, the last one, containing the manual segmentation gives error.

Newbie explanation follows:

It first reads hundreds of MR[…].dcm (edited for privacy) files.
The last good message off the command line is:
“Volume” Reader has successfully read the file “[…]MR[…].dcm”[…]

Immediately followed bu the first error line:
vtkITKArchetypeImageSeriesReader::ExecuteInformation: Cannot open […] RS[…].dcm. ITK exception info: error in unknown: Could not create IO object for reading file […]RS[…].dcm

It obviously does not recognize the segmentation file.

The file is read fine by the first freeware viewer I tried: Aliza.

The Linux “file” command recognizes the RS[…].dcm as “DICOM medical imaging data”.

Questions:

  1. Are there DICOM formats 3DSlicer does not understand?

  2. Maybe I should have loaded a particular module?

  3. How do I find out which DICOM subformat my RS.dcm file is?

  4. Pointers to the right documentation?

Thanks, I hope I don’t have to write an import module!

1 Like

‘RS’ probably refers to DICOM RT structure set object. You need to install SlicerRT extension to be able to load DICOM RT information objects.

I already have both SlicerRT and SlicerRadiomics installed.

New info: Aliza reports RT as RTSTRUCT, and “series” as “Contouring” (which I called “segmentation”). May be useful to identify the right module, if any.

BTW, should I edit the OP with the new info or just leave it here in the comments?

RTSTRUCT can be imported by SlicerRT extension. It has been tested on hundreds of data sets. Could you share the files that you have trouble importing? (make sure it is anonymized)

Ok, anonymized it within Aliza. It’s 12578 bytes and I called it RS…dcm.
How do I share it on this forum?

Also, I get the same error with the RS contour files in the Planning Data directory of the WC2015_Gel_Slicelet_Dataset I downloaded from https://www.slicer.org/wiki/Documentation/Nightly/Extensions/SlicerRT#Tutorials

Does this confirm that there is something wrong with Slicer-4.9.0-2018-09-26-linux-amd64?

Are you sure the SlicerRT extension is installed properly? Do you see a Radiotherapy category in the module list? Do you see DicomRtImportExportPlugin in the DICOM browser if you check Advanced?

In the meantime I’ll try to load the tutorial dataset.

  1. Yes, the Radiotherapy category is listed.
  2. Yes, the DicomRtImportExportPlugin shows up in the DICOM browser.

I’ve tested Planning Data directory of the WC2015_Gel_Slicelet_Dataset from the above post and it worked
with Slicer (current nightly build). In DICOM Browser clicked import, clicked at the study and “Examine”, clicked “Load”

scr1

Screenshot%20at%202018-10-18%2003-46-57