Cannot reach extension web server

Hello, today I was trying to install one extension, but I am unable to access the server. This is the message I get within Slicer’s extension manager:

Extensions can not be installed.

Try Again

I am using Ubuntu 22.04 and Slicer 5.0.3 stable.

I also tried directly entering from different web browsers the extensions website, to no avail.

Is someone experiencing the same?

i meet the problem before and use vpn to solve this problem


oh, I see… so maybe it’s the same issue as in New release 5.0.3, unable to download extension - #2 by lassoan

I solved this now by adding and to the DNS nameservers, without having to use any VPN.

Thank you. These IP addresses are Google’s DNS servers, which are safe to use. Maybe your previous DNS settings were not correct, or the DNS servers were misconfigured (either accidentally, or intentionally - to try to restrict what sites can be accessed).

Well, the default DNS servers were those from my university (local), so probably intentionally restrictive.