Can't open saved MRML file

Operating system: Mac OSX
Slicer version: 4.11.0
Expected behaviour: Open saved MRML file of MRI
Actual behaviour: Zero bytes file and blank screen

I’m not very technically inclined, and have just recently downloaded Slicer to digitise some MRI scans for a project. I have been painting muscle boundaries and saved my work, but then when I try open the file on Slicer nothing happens. Info of the file says it’s zero bytes. There’s no error code, it just doesn’t open anything.

The file is named: 2020-03-08 Scene.mrml

I’m not very proficient with IT or Slicer so please help!

What file has zero bytes? How did you save the scene? How do you open the scene?

If storage space is not a concern, the simplest is to save everything into a single .mrb file by clicking on the package icon in the Save data window.

The 2020-03-08 Scene.mrml file that I saved has zero bytes.
I saved the scene by the ‘command+S’ and just clicked enter, saving it by the default which created the mrml file. I didn’t click on anything else in the Save data window.

To try open the scene, I clicked the upload data icon in the top right of the toolbar and tried to open it here. I also tried opening the file by right clicking it in the desktop and choosing an application to open it but this didn’t work either.

If the mrml file has zero length then it is empty and you cannot open it. Was any error logged during file scene saving (you can find logs of current and last 10 sessions in menu: Help / Report a bug)? Is the problem reproducible with any of the Slicer sample data sets (in Sample Data module)?

I have saved a new set of MRI slides as an ‘.mrb’ file and it still won’t open on my Slicer programme.
Attached is the error messaged displayed when trying to open the medical reality bundle. There’s lots of error messages saying there was an error loading file. I don’t have much space on my computer but have been trying to save my data on a server using a VPN from my university.

It appears that specific traceback error was resolved on March 5th
so would’ve been included in any Slicer Preview build since March 6th.

Since the file has zero length you won’t be able to recover that work, but I would suggest trying again whatever you were attempting with the latest Slicer preview from

1 Like