Problem with loading an mrml

Operating system: win10
Slicer version: 4.10.2
Expected behavior: Previously if we clicked onto an mrml file it loaded the entire scene - CT sequences, models, segmentations.
Actual behavior: Upon loading a Slicer mrml file, it does not show either the CT sequence or the segmentations. We tried overloading them on top of each other but no result.
The root of the proble is perhaps that my collague started to work from a pendrive and it all worked fine. She could reopen here projects. But than she copied the files onto the computer and now it does not work. Not even if she puts it back onto the pendrive. What could be wrong? Is it possible that we have to start all over again? How to avoid such incidents?

The MRML file does not store bulk data (images, models, segmentations, etc), just the relative paths of the data files (NRRD, STL,… files).

You either have to manually copy all the related data files along with the “mrml” file, or save all data in the scene in the single-file, portable “mrb” (MRML bundle) format. You can switch between mrml / mrb format by clicking on the package icon in the “Save data” window.

Thanks for the reply. The question is, is there a way to recover once the files are messed up? In other words, how can I read the original structure from the mrml file? If the user didn’t tick the “segmentations”, then we lost the file, did we?

Original in Hungarian

Köszönöm a választ. A kérdés az, hogy van-e mód arra ,hogy ha egyszer összekutyulódott a file rendszer, akkor visszaálljon? Máshogy fogalmazva, hogy tudom kiolvasni az eredeti struktúrát az mrml fileból? Ha a lány a “segmentations”-t nem pipálta ki, akkor azt buktuk, ugye?


By default all modified files are automatically selected for saving. Unless the user has manually unchecked the checkbox in Save data window, the file is saved somewhere and you can load it into Slicer by drag-and-drop / Add data.

Thank you so much!
Reinitz Laci

1 Like