Changing node name for volume and not saving .nrrd file overwrites file path in the scene

Hi all,

I loaded a single slice DICOM - name: “l3.dcm” (say) - as a volume. The node created is “l3.dcm”.

I changed the node name in the Data Module from “l3.dcm” to “subject1” and hit save. I saved the .mrml scene file but NOT the .nrrd. After closing Slicer, I tried to open the .mrml scene and no data is loaded.

I opened the .mrml with Notepad and it looks as if the fileName path is being changed to the node name I designated. It appears if I choose not to save the .nrrd, it is not possible to have different node names and the file names.

I feel this is a bug because typically the expected behaviour would be that node name changes should affect the file path.


This is the current behavior: node name changes affect the file path.

I see how it may be unexpected that you are allowed to edit the filename even when the box is unchecked. I’ll add a note to this related issue.


…expected behaviour would be that node name changes should NOT affect the file path.

This was the original behavior, but it caused lots of confusion among users. For example, they updated node names in the scene, but they forgot to rename files accordingly when they saved the scene.

As an engineer, I would prefer if node renames did not update the filenames automatically, but as a Slicer user, I have to admit that this mechanism saves time and make things safer.

This indicates that you loaded DICOM using “Add data” dialog. This is a loophole that we haven’t closed yet, but you should always load DICOM data using DICOM module. We will disable DICOM loading via “Add data” when we are sure that we sufficiently simplified loading via DICOM module.