Changing volume jumps the slice

In the Data module I may have several scalar volumes from the same scanning but with different postprocessing, or manually modified in Slicer like crop volume or an image filter.

My problem is that if I change the current visible volume (press the closed “eye” button in Data module), the slice(s) jumps to the center of this volume. Is this a bug or a feature? Or is there a setting to prevent this? Because when I now use ITK SimpleFilters on an image and want to look at the difference for a specific slice, the slice position is reset so I have to scroll back to this slice. However, jump to center does not happen when I change volume in a slice controller’s drop-down selector (this does not help when I work with the SimpleFilters module anyway).

I also found this default behavior annoying and unexpected. I expected clicking the eye to be basically the same as switching the background image volume on all the slice views, i.e. that it would not change the location or orientation of the slice views, just change which volume I was viewing at that location. I began to write a response to you expressing support for having the option to change the behavior, and thought about how this should be implemented. What came to mind was that it would make sense to have this option available on a context menu by right-clicking on the eye. It occurred to me that I had never tried actually doing that. I tried it, and this feature is already available :slight_smile: Here is a screenshot.


We just want to uncheck those boxes which reset the view and orientation.


Thank you, this was exactly my problem and a fully working solution :smiley: I was searching for this setting but couldn’t find it. Slicer’s right click menus contains several secrets.

1 Like