Command 'elastix' died with <Signals.SIGABRT: 6>.


I am using a MacBook and Slicer 5.5.0

First I had many issues to find a version that allowed the SlicerElastix downloading.

Now when I put my inputs brain files and output + specify the active volume and the lookup table + click on “apply”, Elastix it not able to compute the results and send back the following error message :
“Command ‘elastix’ died with <Signals.SIGABRT: 6>.”

Traceback (most recent call last):
File “/Applications/”, line 3146, in tryWithErrorDisplay
File “/Applications/”, line 241, in onApplyButton
File “/Applications/”, line 518, in registerVolumesUsingParameterNode
File “/Applications/”, line 564, in registerVolumes
File “/Applications/”, line 499, in logProcessOutput
raise subprocess.CalledProcessError(return_code, “elastix”)
subprocess.CalledProcessError: Command ‘elastix’ died with <Signals.SIGABRT: 6>.

Chat GPT says that it’s an error inside the python script, I don’t know how to access it. And I need this data processing step for my research.

Please if anyone could help with this. :slight_smile:

Have you specified some custom Elastix binaries? Was there any issue with the binaries that are bundled with the extension?

Thank you for the quick answer, I just loaded the “SlicerElastix extension” as it was in the “Install Slicer extensions”, without any custom.

Could you please try with the latest Slicer Preview Release?

unfortunately, it gave the same error message on Slicer 5.4.0. This is why I tried a more ancien version.

Could you please try with the latest Slicer Preview Release (Slicer-5.5.x)?

I tried the latest version stable, slicer 5.6.0, it gave me the same error message. Do you thing we can resolve this?

I have the same issue (also on MacBook). The log window says it cannot find libomp.dylib. I have installed that one using Homebrew, but Slicer is not looking for it in the Homebrew directories but in the extension directory and /usr/lib, /usr/local/lib

Thank you, this explains it. OpenMP is a pain. You probably have dozens of mostly incompatible variants on your system. Elastix should not try to use that are on your system, because most likely they will not work (because they are probably not the same version as the one used when building Elastix).

A workaround that you can apply immediately is to download Elastix binaries (or build Elastix on your system) and specify that path in the Advanced section of the Elastix module in Slicer.

The root cause of the issue could be fixed by bundling libopenmp.dylib with the SlicerElastix extension or disabling OpenMP when building the extension. Your can monitor the status of the fix here: