Compile the latest fails

Operating system: windows10
Slicer version: latest version (5.0)
Expected behavior: compile the “buildall” project
Actual behavior:*
all the configuration according to " Windows — 3D Slicer documentation"
git version 2.36.0., cmake version 3.23.1, VS2022 V143

when compile with ““C:\Program Files\CMake\bin\cmake.exe” --build . --config Debug” it had the following error:


It seems that your computer had problems accessing github. Check your network (firewall, proxy, vpn, …) settings and try again. We build Slicer on Windows, Linux, and macOS and there have been no build errors recently.

thanks Lassoan.
I shut the proxy and the auto-detect opened

btw, I tried the git by cmd git clone GitHub - commontk/DCMTK: WARNING: This is NOT the official upstream DCMTK git repository. it works well but by ““C:\Program Files\CMake\bin\cmake.exe” --build . --config Debug” fail

I modified git protocol:
git config –global url.”https://”.insteadOf git://
OpenSSL connecting proxy setting:
git config --global http.proxy
git config --global https.proxy
they seem to be the solution of connection with github repository.

but i still have the “Project Completion Failure” in VS2022

it seems no solution/download link for this project

Are you connecting to the internet via a proxy server?

You then need to specify it for every Neutrogena access operations. It seems that you figured it out how to do it for git. You also need to specify the proxy server for Python"s pip. Setting the -HTTP_PROXY=<proxyserver_name>:<port#> environment variable may be sufficient.

Thanks, I am trying to do with your instruction as below hope it is right…

but still the python has project failed in building (but i find the executable(.exe) application of Slicer in the folder). So I am thinking do the python- affixed projects need to be built? As I saw when building : No download step for 'python-wheel' No update step for 'python-wheel'

Creating directories for 'python-setuptools'
Building Custom Rule C:/D/S/CMakeLists.txt
No download step for 'python-setuptools'
No update step for 'python-setuptools'
Generate version-python-setuptools.txt and license-python-setuptools.txt
fatal: not a git repository (or any of the parent directories): .git
CMake Warning (dev) at C:/D/D4R/CMakeFiles/python-setuptools-generate-project-description.cmake:69 (message):
  python-setuptools: Could not find a license file
This warning is for project developers.  Use -Wno-dev to suppress it.

No patch step for 'python-setuptools'
No configure step for 'python-setuptools'
No build step for 'python-setuptools'
Performing install step for 'python-setuptools'
CMake Error at C:/D/D4R/python-setuptools-prefix/src/python-setuptools-stamp/python-setuptools-install-Release.cmake:49 (message):
  Command failed: 1

   'C:/D/D4R/python-install/bin/PythonSlicer.exe' '-m' 'pip' 'install' '--require-hashes' '-r' 'C:/D/D4R/python-setuptools-requirements.txt'

  See also


C:\Program Files\Microsoft Visual Studio\2022\Community\MSBuild\Microsoft\VC\v170\Microsoft.CppCommon.targets(245,5): error MSB8066: Custom build for 'C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-mkdir.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-download.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-update.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-patch.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-configure.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-build.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-generate_project_description.rule;C:\D\D4R\CMakeFiles\48d8ac0d9c1890032347ba8b3181d423\python-setuptools-install.rule;C:\D\D4R\CMakeFiles\ee0ff0a71f8955ced5249e2ec794c4aa\python-setuptools-complete.rule;C:\D\D4R\CMakeFiles\a478b26e6350678435a4bc11611aaba7\python-setuptools.rule;C:\D\S\CMakeLists.txt' exited with code 1.
Done building project "python-setuptools.vcxproj" -- FAILED.```

Python’s package manager and pip tool is not related to CMake. You need to set HTTP_PROXY/HTTPS_PROXY as environment variable in your operating system.

Thanks Lassoan,
There is still a little error (MSB8066) about python-setuptools project;
Locate in the file: <CustomBuild Condition ="'@(_CustomBuild)' != ''"

I tried to build specific error project, this is the error with pythonproject

I locate to the folder C:\D\S4R\CMakeFiles\b971bae278932486b6f223c6e29c96a3
and I find the XXX.rule file writes # generated from CMake but nothing.

I sometimes solve this errors by rebuilding the whole project again from zero

Check out the “Common errors” section of the build instructions to see how to solve Python related build errors.

1 Like

Thanks for the replies. I will try.

1 Like