Crop Volume Shutdown

I am encountering rather strange behavior of 3D Slicer when it comes to cropping the volumes of .nii files. Most of the files that i am working are 3 GB +. I have recorded a clip of this rather strange behaviour.

  1. Load the volume
  2. Select ROI and save the scene
  3. cropping volume ( interpolator linear or windowed sinc behave the same way)
  4. 3D slicer shutdown in the middle but in the temporary folder can see the cropped volume (nrrd) file saved. (But 3D Slicer must be working in the background as the file is written after it is shutdown)
  5. restart it and load the scene and do the same thing it works fine.

I was thinking this was happening due to running out of memory in my machine but is this something else ?

You need much more memory to keep the original volume in the scene and load the cropped volume as well, than just load the cropped volume in an empty scene. However, there should be no problem if you have enough virtual memory/swap space (10x more than the size of the data set - about 30GB).

Thank you for the explanation but how does it do it the second time around always with the same settings ?

I think this is something to do with Linux Mint version i am using rather than swap space. I installed Elementary OS and with default swap of 1 gb this works. So guess it is something more to do with the OS.