Dark lighting/shadow issue when rotating the model

Is there any way to resolve the darkness/shadow when I rotate this model output I obtained from ALPACA?

Not sure what is happening. It is fine when I look at the model at a certain angle though.

I would simply like the lighting to be uniform everywhere. I’ve fiddled around with Lights extension however struggling to achieve so. Is there a way to remove shadows altogether?

Resolved - Changed the “Interpolation” under models to Flat

It looks like your model was turned inside out. If that is indeed the issue then you can fix it in Surface Toolbox module (compute surface normals section, enable “Auto-orient normals”).