DentalSegmentator extension is not working

Hello
I get this error
Failed to load the segmentation.

Check the inference folder content C:\Users\artur\AppData\Local\Temp\Slicer-vFmJLy\output

How i can fix it?

hello
first i would like to congratulate for this extension.
super cool stuff
i would like to inform you that i have installed the new version of slicer plus the extension… and tried but its not working even after upgrading pytorch can you help me

Hi @ARtur_Zhumabekov and @Drhamidhmd,

Thank you for trying out our module.

Could you provide us with the following information so that we have a clearer view on what went wrong :

  • Which OS did you try the module on
  • Which preview version date did you try it on. Slicer previews are built nightly and we made several fixes to the extension since it was added to the extension manager and you may want to test on the latest preview release to check if the problem is still there.
  • What is your machine configuration (RAM / CPU / GPU config)
  • Could you give us the information available in the module log. The logs are accessible by clicking on the (i) button next to the apply button
  • Could you give us the information available in the Python console

Thanks in advance.

Best,
Thibault

1 Like

Thanks for response.
My problem got resolved… as pytorch was not working… I reinstalled it’s working properly.
But it’s working with CbCt but not with medical ct scan

@Drhamidhmd thanks for the update. Glad to know that it now works for you with your CBCT.

When you say the module doesn’t work with medical CT Scan, what do you mean? Does it not output the segmentation you are expecting? Does it not run to completion?

Actually I uploaded the Medical scan on slicer and tried running the Dental segmentator…it took longer than normal time and got hanged… happened many time

First i would like to congratulate for this extension.
I came across a mistake :

RuntimeError: Invalid nnUNet configuration. Model folder is missing the following folds : [0].
Your model weight folder path should look like the following :
Dataset<dataset_id>/<trainer_name>__<plan_name>__<conf_name>

It should also contain a dataset.json file and fold_<i_fold> folders with model weights.

Provided model dir :
D:\ProgramData\slicer.org\Slicer 5.7.0-2024-05-15\slicer.org\Extensions-32859\DentalSegmentator\lib\Slicer-5.7\qt-scripted-modules\Resources\ML

I read the related .py file.
It seems the path “DentalSegmentator\Resources\ML” created in SlicerDentalSegmentator is not well recognized by the nnUNet library.
In addition, the 3D Slicer is 5.7.0-2024-05-15 r32859 / 332732c, the nnUNet is Version:edb9b03 (2024-05-16).

Hi @the_ice ,

Thank you for your feedback and your interest in our extension.
It seems the model may not have been correctly downloaded / extracted in your ML folder.

To make up for that, you can follow the troubleshooting here : GitHub - gaudot/SlicerDentalSegmentator: 3D Slicer extension for fully-automatic segmentation of CT and CBCT dental volumes.

It consists in :

  • Downloading the latest .zip file from the release and extracting it in the DentalSegmentator\Resources\ML folder
  • Creating a download_info.json in the ML folder with the following content : { "download_url": "https://github.com/gaudot/SlicerDentalSegmentator/releases/download/v1.0.0-alpha/Dataset111_453CT_v100.zip" }

Please let me know if that solves the issue on your end.

Best,
Thibault

Thank you very much! The advice you gave me was very precise. :+1: :+1: