Dicom File Loading Spacing

Two Questions:

  1. I have dicom files from MRI which have all necessary metadata, however, only some of the files are consecutive, while others are skipped in between (i.e Dicom 001, Dicom 002, Dicom 007, etc.) The ImagePositionPatient says the spacing is .3mm, and from the 43 files I have, the total length is ~55mm due to skipped slices. However, when loading these Dicom files in, it truncates all the slices so that the first one is positioned correctly, but then each following slice is just .3mm away, even though there are some instances where 5mm should be skipped based on the ImagePositionPatient data. This results in the total length only being 42*.3mm = ~12mm. Is there a way for Slicer to obey this metadata header for all slices so spacing is preserved?

  2. For the length of a volume that was created via segmentation, it is possible to get the volume of each slice individually after the model is created? I am interested in the areas of all the segmented slices, but have only been able to do this by loading in a single slice at a time.

Thanks for any help on either of these!

Eli

Hi -

For number question 1, you can turn on geometry regularization and it should automatically handle the missing slices:

image

For question 2 I can’t think of an easy way to do this. A little python script would be the easiest. Or do it manually to create new segments per slice (maybe using the segment overwrite options in the Segment Editor.

1 Like

See this topic: Calculating Simple Areas

Hi Steve and Andras,

Thanks for the responses.

When turning on geometry regularization, the slices are now placed in the correct location. However, when segmenting, I am unable to add masking to any slices that are past the max z location of the previously truncated series. The truncated z
location range went from ~ -4 β€”> 7.6mm with a thickness of .3mm, while the actual series should be from -4 β€”> 50mm with a lot being skipped. With geometry regularization turned on, I am only able to add masking to slices up to 7.6mm. The performance of the
program is also drastically slowed. Any ideas on what is going on here?

I am using the latest stable build on Mac as of today.

Thanks,

Eli

Probably default segmentation labelmap geometry is not computed optimally for non-linearly transformed images. You can adjust it by clicking the button next to the master volume selector (see this post for some instructions).

Or, you can harden the regularization transform using Transforms module.