Does Slicer support external graphics cards?

#1

Operating system: OSx high sierra
Slicer version:4.8
Expected behavior:
Actual behavior:

Slicer keeps using all of my CPU so I’m thinking about getting an external graphics card like this:

Will that work?

0 Likes

(Andras Lasso) #2

I think it should not matter for applications if you use internal or external GPU. However, only certain operations benefit from a strong GPU, such as volume rendering, or rendering of models that have hundreds of thousands of points. What operations do you do often and take too long?

Most likely you would get much better overall performance if you get a gaming laptop instead of just upgrading the GPU. Additional advantages are that you don’t need to deal with clunky external GPU, you can use virtual reality, and total cost may be lower, too.

0 Likes

#3

I have uCT data 1200 slices and each .dcm files is about 2.4MB. I need to segment the external and internal anatomy and my computer keeps crashing. Every time I click, the program takes at least 30 seconds to respond. I tried Horos and they don’t have this problem at all. Unfortunately, they don’t have the features I want and there is no free support so I am going back to 3D slicer which I can’t do with my current computer configuration. Here is what I’m working with:
MacOS High Sierra 10.13.4
Processor: 3.5 GHz Intel Core i7
memory: 32 GB 1600 MHz DDR3 (This was upgraded from 8GB that the computer came with)
Graphics: NVIDIA GeForce GTX 775M 2048 MB

It seems like that could be enough but that’s not how the program acts when I am segmenting in 3D slicer. I have access to a newer computer where I can upgrade to 64GB RAM and I was thinking about getting that Radeon video card I mentioned in my earlier post.

Since I have a computer I can switch to, I would like to make it useable rather than buying a whole new computer.

Thank you for your input!

Freya

0 Likes

(Murat Maga) #4

You need to give a bit more information. For example what module is crashing, and what are you clicking on? Is the issue during the load or the segmentation?

0 Likes

(Andras Lasso) #5

Slicer uses OpenGL for rendering, so rendering speed should be automatically improved if you attach an eGPU and configure your system so that Slicer uses it. However, this most likely to improve the problems that you have mentioned.

I’ve worked with larger data sets without problems. In general, memory space may be an issue for large data sets, but 32GB should be OK to get started (especially if you have a hundred GB free disk space to make absolutely sure you don’t run out of memory space). So, as @muratmaga mentioned, we need more information to help - have you enabled “Show 3D”, what effects do you use, etc.?

You may try to downsample your volume by a factor of 2 on all axes, which would result in 8x less memory usage. It is also worth cropping your volume to the minimum size. You can use Crop volumes module for both.

0 Likes

#6

Good questions. I am now using a computer with 900GB free storage and the following guts:
processor: 4.2 GHz Intel Core i7
Memory 8 GB 2400 MHz DDR4 (can be updated to 64 GB)
Graphics: Radeon Pro 575 4096 MB

I think I had about 300GB free storage on the last computer. I was using a plugin called segmentation wizard. I think I cropped the volume but I will try again. I never got to any volume rendering because my computer told me I had used all available memory and I needed to quit the program before I could finish segmenting the whole animal. Every click was so slow I wasn’t getting anywhere so I tried Horos which performed much better on my computer but I’m not happy with the useability and lack of support. Needless to say, I’m very grateful for your help in trying to figure out the best configuration.

0 Likes

#7

I have not knowingly enabled “show 3D”. I will look for that.

0 Likes

(Andras Lasso) #8

8GB RAM for editing an almost 3GB volume will be very slow. In general, I recommend 10x more RAM than the main working volume size. If increasing RAM size is not easy then crop and resample your volume to make the volume size smaller (as I described above). After cropping is completed, delete the original full-size volume from the scene.

Segmentation wizard extension has been developed for one particular segmentation task. It is not for general purpose segmentation and may work very inefficiently. Use Segment editor module instead.

0 Likes

#9

Yes you are right it’s slow. It has been working on cropping the volume for the last 20 minutes. Not much different from the other computer that had 32 GB RAM but it’s at least doing something. I need a segmentation editor where I can manually draw a shape every few slices, then have the program interpolate between those. For the external volume, I was using segmentation wizard because it was going by pixel brightness and then I was using the volume brush to correct things. I’'ll see if I can do the same in Segment Editor.

Thank you for the tip on deleting the full-volume. I don’t know how to do that but I will figure it out. Thanks again for your help!

Freya

0 Likes

(Andras Lasso) #10

Click on the volume node selector and select “Delete”. If “Delete” is not an option there then you can always go to “Data” module, right-click on the volume and click “Delete”.

You can do all these using Segment editor effects.

This is provided by “Fill between slices” Segment editor effect.

0 Likes

#12

more details of GPU graphics and configuration of pc is required inorder to say whether slicer will support or not

0 Likes