DWIConvert Issue

I am having some trouble importing dicom files and converting them to dwi. I saw a few threads in the forum on this issue (for example, this, this). I get the same error, which says “itk::ERROR: LoadFromDisk not relevant”. These files can be loaded normally by DICOM browser but it is not recognized as DiffusionWeightedNode (I am trying to repeat this video) even I manually saved them into nrrd file through the SAVE module. And it also appeared garbled just as @iassoan showed in his post. I am not sure if these data are taken from SIEMENS machine, since the manufacturer tag is empty. Here is the dropbox link to the data: Dropbox - 4-Ax DWI-46959 - Simplify your life, and it is also publicly available at TCGA-GBM database (Patient 06-0184, study 12-29-2007-61185, series AX DWI). I have also tried other DWI series but none of them works. From all the other posts, I could not find a very clear solution to this problem. Any help would be greatly appreciated!

BTW, I tried to install the latest nightly build (v4.9.0, revision 27131, built on April 9th) to see if it is resolved in this latest version. But when I opened it, it shows nothing (not exactly nothing since I can vaguely see the interface as below):

I have stable 4.8.1 version installed and my hardware is not old (I7-6700K+GTX1080+Windows10 64 bit). Any ideas why it looks like this?

Hi @zjx1805, I checked the data, and the issue is exactly the same as in the thread you linked, specifically this answer: the data is very aggressively anonymized, so it is missing the tags required to reconstruct as a diffusion volume (gradients, b-value, and even manufacturer are all removed).

For reference, here is the CTP script probably used for these TCIA datasets:


Note at the bottom, any tags which are not specifically permitted are removed (which means that the private DICOM tags used to store diffusion parameters were removed, as we observe).

(and related discussion)

Hi ihnorton, Thank you for your confirmation. Does that mean there is nothing I can do with these data? BTW, I am wondering if you have the same issue as me with the 4.9.0 nightly build?

Correct, unfortunately there is no way to process this data as diffusion MRI.

Thank you anyway for your help!

1 Like