Error of cleaver while using segmentmesher

Hello all,
I am trying to mesh my model using segmentmesher (cleaver). When the resolution of model is high, I can do meshing without any problems; however, when I decrease the resolution of my segmentations, I get an error while my segmentation quality is still very good. This is the error I get:

"Nrrd file read error: No zero crossing in indicator function. Not a valid file or need a lower sigma value.

Command ‘cleaver-cli’ returned non-zero exit status 11."

I do not understand what problem in my segmentation can cause this error. Can you give me some cases that can lead to this error or help me to solve this problem?
Thanks in advance

[quote=“Aep93, post:1, topic:16128”]
"Nrrd file read error: No zero crossing in indicator function. Not a valid file or need a lower sigma value.
[/quote]s

This means that the method gets an empty segment, most likely because there is a small structure that gets completely removed during preprocessing steps (sampling and Gaussian smoothing). You can either hide the segment to exclude from meshing, increase sampling rate, or lower blending function sigma (by specifying --blend_sigma 0.5 as additional command line option).

Thanks for your response @lassoan. I understood that this problem happens when I scale down my segmentation. So, I have a segmentation for which I can produce mesh without any problems. Then I use the transform module to make my segmentation smaller. Then I get this error when I want to mesh my scaled segmentation even though the resolution of the scaled segmentation is the same as the original one and only the dimensions have changed.
Am I missing anything during scaling? should I do additional steps to complete my scaling?

What do you mean by scaling down? Changing unit from mm to cm or inches? Or decrease the number of elements?

I enter a value smaller than 1 in the diagonal elements of first three columns in the transfer module and use this transformation to make my segmentation smaller. (I do it for changing units)

I would recommend to not change units. If you must change units then do it as the very last step (transform the output of Segment mesher), just before saving the mesh.

1 Like

OK @lassoan, I will convert the units in my last step then. Thanks for your response.

1 Like