SegmentMesher, Error: Command 'cleaver-cli.exe' returned non-zero exit status 3221226505

Operating system: Windows 10
Slicer version: 5.2.2
Expected behavior: Creating volumetric mesh
Actual behavior: Error: Command ‘cleaver-cli.exe’ returned non-zero exit status 3221226505

Hello everyone,

I have a Segmentation.seg.nrrd file which include four segments. I want to create volumetric mesh of that. But when I choose that and run SegmentMesher, it gives me the following error:

Error: Command ‘cleaver-cli.exe’ returned non-zero exit status 3221226505

I have tried it several times, even by one segment but got the same response.
Please let me know if you have any suggestions to solve this issue.

Best wishes

Try to adjust the parameters to generate a smaller, simpler, less accurate model to see if the mesh generation succeeds then.

Thanks for your attention.
In fact, it does not generate mesh for a simple small tumor.

I installed this extension on another computer with same system and it works.
So it seems that the model is not the problem.

Do you have any suggestion in this regard?

Many thanks

It may be possible that language/regional settings in your operating system cause problems - indicated by the special characters in the working directory.

Could you try changing this line to the line below and test if it resolved the issue?

    tempDirName = "test123“

Thank you for your response. I have installed the software in Windows 10 and to change this code I would try installing in Linux this weekend.

However, I wanted to analyze the output in COMSOL and I got it from the other computer. But I found that I can’t import .vtk or .msh into COMSOL. It seems that importing mesh file into COMSOL is much more complicated than other format specially for adding different physics. Also, I tried Gmsh and Salome to convert it to other importable formats. This wasn’t successful, too.

On the other hand, when I saved the model as STL format, it gives me a specific error in COMSOL (Geometry error (fin): Self-intersecting curve)
Is there anyway to improve the quality of STL file that 3D Slicer gives us? Or any ideas to solve this issue?

Hope the best,

Some users reported that they successfully converted VTK volumetric meshes using meshio Python package. You can install it into 3D Slicer’s Python environment by opening the Python console, typing pip_install('meshio'), then follow examples of the meshio package documentation.

Yes, as always you are right. It was due to language settings.

How ever I changed it in control panel. In fact, I didn’t understand in which section of program I need to change this code. I need to change line number 638, but where? Could you tell the path.

Many thanks