Failed to fetch models from remote server. make sure server address is correct and <server_uri>/v1/models is accessible in browser

Hello. 3D-Slicer members.

I have used well NVIDIA AIAA module in 3d-slicer since June first, 2022.

However, it occurred some error nvidia aiaa module in 3d-slicer yesterday.

The occurred error is as following.

  1. When I run segment editor, and then I pressed nvidia aiaa effect button in segment editor module. but nvidia aiaa didn’t work in 3d-slicer.
    I confirmed error message that ‘failed to fetch models from remote server. make sure server address is correct and <server_uri>/v1/models is accessible in browser’.

I conducted well modeling using nvidia aiaa effect in segment editor of 3d-slicer until 2days ago.

I don’t know why this error occurs to me.

Please, let me know how to solve this error.


Sometimes, it seems to stop network communication managing NVIDIA AIAA server because of the latest updates to the extension.

please check whether network communication regarding NVIDIA AIAA server run or not.

1 Like

I checked revision of 3d-slicer(revision 31260 built 2022-11-02) today.

After I reinstalled as revision version and I ran 3d-slicer program, I pressed nvidia aiaa effect button in segment editor module.

But It also occurrs same error occurred in last version such as having that
‘Failed to fetch models from remote server. make sure server address is correct and <server_uri>/v1/models is accessible in browser.’.

Does it have how to solve regarding this error?

I’ll check this. Our university tightened restrictions of public access to servers, so I may need to request an exception to keep this service going.

1 Like

Thank you for answering my quesion. If the server access problem is solved, please let me know in reply that the problem has been solved.

The server is back online. Let me know if you still encounter any problem.

Note that development of NVIDIA AI-Assisted Annotation server is stopped and its developers recommend to switch to MONAILabel.

1 Like

Dear @lassoan

After I had checked your answer, I tested NVIDIA AIAA module in 3D-Slicer.

It is working well in 3D-Slicer.

From now on, I will try to handle MONAI Label.

Thank you helping me.

1 Like

HI everyone,

Failed to fetch models from remote server

‘Failed to fetch models from remote server. Make sure server address is correct and <server_uri>/info/ is accessible in browser’
Traceback (most recent call last):
File “C:/Users/aaron/AppData/Local/NA-MIC/Slicer 5.2.1/NA-MIC/Extensions-31317/MONAILabel/lib/Slicer-5.2/qt-scripted-modules/”, line 1071, in fetchInfo
info =
File “C:/Users/aaron/AppData/Local/NA-MIC/Slicer 5.2.1/NA-MIC/Extensions-31317/MONAILabel/lib/Slicer-5.2/qt-scripted-modules/”, line 2196, in info
return MONAILabelClient(self.server_url, self.tmpdir, self.client_id).info()
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\NA-MIC\Extensions-31317\MONAILabel\lib\Slicer-5.2\qt-scripted-modules\MONAILabelLib\”, line 50, in info
status, response, _, _ = MONAILabelUtils.http_method(“GET”, self._server_url, selector)
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\NA-MIC\Extensions-31317\MONAILabel\lib\Slicer-5.2\qt-scripted-modules\MONAILabelLib\”, line 303, in http_method
conn.request(method, selector, body=body, headers=headers)
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 1285, in request
self._send_request(method, url, body, headers, encode_chunked)
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 1331, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 1280, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 1040, in _send_output
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 980, in send
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\http\”, line 946, in connect
self.sock = self._create_connection(
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\”, line 844, in create_connection
raise err
File “C:\Users\aaron\AppData\Local\NA-MIC\Slicer 5.2.1\lib\Python\Lib\”, line 832, in create_connection
TimeoutError: [WinError 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

May I please have some help with this. I cannot connect to the MONAI server my supervisor created

Sorry, still very new here and to 3d slicer/MONAI

I’m facing the same error when clicking refresh button.

note: I’m working on windows and didn’t install any prior packages before use MONAI label. just install it from extensions manager on 3d slicer

Thats only the client side of the MonaiLabel. You need to install the MonaiLabel server, which actually does the work. GitHub - Project-MONAI/MONAILabel: MONAI Label is an intelligent open source image labeling and learning tool.

If you nust want to run pretrained models then you don’t need to set up a server, but you can use MONAIAuto3DSeg, TotalSegmentator, etc. extensions. What are you trying to achieve?