Slicer error when using Nvidia AIAA

Operating system: Windows 10
Slicer version: 4.11.0
Expected behavior: fetch models from remote server
Actual behavior: fail

i got error when trying to use Nvidia AIAA,i am using MRBrainTumor1 from Sample Data Module.neiter can i enter the server address, nor can i leave it empty
Failed to fetch models from remote server. Make sure server address is correct and <server_uri>/v1/models is accessible in browser

details
Traceback (most recent call last):
File “C:/Users/mehmetcane/AppData/Roaming/NA-MIC/Extensions-28798/NvidiaAIAssistedAnnotation/lib/Slicer-4.11/qt-scripted-modules/SegmentEditorNvidiaAIAALib/SegmentEditorEffect.py”, line 196, in fetchAIAAModels
models = self.logic.list_models()
File “C:/Users/mehmetcane/AppData/Roaming/NA-MIC/Extensions-28798/NvidiaAIAssistedAnnotation/lib/Slicer-4.11/qt-scripted-modules/SegmentEditorNvidiaAIAALib/SegmentEditorEffect.py”, line 1021, in list_models
return aiaaClient.model_list(label)
File “C:\Users\mehmetcane\AppData\Roaming\NA-MIC\Extensions-28798\NvidiaAIAssistedAnnotation\lib\Slicer-4.11\qt-scripted-modules\NvidiaAIAAClientAPI\client_api.py”, line 191, in model_list
status, response = AIAAUtils.http_method(‘GET’, self._server_url, selector)
File “C:\Users\mehmetcane\AppData\Roaming\NA-MIC\Extensions-28798\NvidiaAIAssistedAnnotation\lib\Slicer-4.11\qt-scripted-modules\NvidiaAIAAClientAPI\client_api.py”, line 572, in http_method
conn.request(method, selector)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 1239, in request
self._send_request(method, url, body, headers, encode_chunked)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 1285, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 1234, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 1026, in _send_output
self.send(msg)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 964, in send
self.connect()
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\http\client.py”, line 936, in connect
(self.host,self.port), self.timeout, self.source_address)
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\socket.py”, line 724, in create_connection
raise err
File “C:\Users\mehmetcane\AppData\Local\NA-MIC\Slicer 4.11.0-2020-03-01\lib\Python\Lib\socket.py”, line 713, in create_connection
sock.connect(sa)
TimeoutError: [WinError 10060] The connected is not responding within a certain period of time accordingly or associated
connection failed

how can i fix this, thank you.

Are you behind a corporate firewall? Do you need to use network proxy to access the internet? Can you open the http://skull.cs.queensu.ca:8123/ link without specifying proxy settings in your web browser?

1 Like

I got the error while connected to the university network.I had no problems when I came home. I will try open the http://skull.cs.queensu.ca:8123/ link when i back to school tomorrow.
Thank you for your interest.

1 Like

Hi,

What would be the solution if we have to use the university network that does not open this link? Any other way to connect to the server?

1 Like

The server address is subject to change. Follow these steps to connect to the current server:

  • If you use the Slicer Stable Release (Slicer-5.0.x): uninstall and then install the NvidiaAIAssistedAnnotation extension
  • If you use the Slicer Preview Release (Slicer-5.1.x): install the latest Slicer Preview Release and then install the NvidiaAIAssistedAnnotation extension
  • In Segment Editor module / Nvidia AIAA effect, clear the “Nvidia AIAA server” field to use the new default server address.

I met the same problem. Have you solved it, please?

The instructions that I provided above should fix the issue for you. The server works using the same protocols as all websites, so it should work even behind proxy servers and firewalls (unless your network administrators explicitly prohibited connecting to servers at Queen’s University in Canada).

Thank you very much for your reply. Yes, it works at home. But maybe my institute, CRCHUM( Centre de recherche du Centre hospitalier de l’Université de Montréal) blocked the server website. I cant use it there. I also tried using the Proxy and closing virus protection and firewall. It still did not work.

If your institution uses a proxy server then setting http_proxy and https_proxy environment variables may help. But if the proxy is very tricky then it may be necessary to set up your own server within your institution.

When I remove “Nvidia AIAA server” and put “http://127.0.0.1:8000/”, I still get the error!

http://127.0.0.1:8000 works if you set up an NVIDIA Clara server on your computer at port 8000.

Nvidia Clara server?! I am not sure if I have that installed on my computer!

Setting it up is a lengthy process. If you are not sure then it means you haven’t set it up. You either need to connect to the default server or set up your own server. You may also consider using MONAILabel instead, which is easier to set up.

This actually happens when I use MONAI Label. It does not connect to the server.