Failed to fetch MONAI label server

Operating system: Windows 7 Build 6.1.7601
Slicer version: 4.13.0 2021-08-16
The version of Python: Python 3.6.7
Expected behavior: Fetch MONAI label server and start Deepedit
Actual behavior: failed

I have setuped MONAI & MONAI label at my workstation, which running ubuntu 18.04. Both fetch local MONAI label server & Deepedit work fine at ubuntu server under 4.13.0 2021-09-29 build

The address of MONAI label server is correct and can be opened in browser at both windows 7 & ubuntu.

But when I use the 3D slicer client with MONAI label plug-in at windows 7, it failed to fetch MONAI label server and showed following error message:

KeyError: 'config’Traceback (most recent call last):
File “C:/ProgramData/NA-MIC/Slicer 4.13.0-2021-08-16/NA-MIC/Extensions-30121/MONAILabel/lib/Slicer-4.13/qt-scripted-modules/”, line 960, in onClickFetchInfo
File “C:/ProgramData/NA-MIC/Slicer 4.13.0-2021-08-16/NA-MIC/Extensions-30121/MONAILabel/lib/Slicer-4.13/qt-scripted-modules/”, line 987, in fetchInfo
self.config = info[“config”]
KeyError: ‘config’

I also tried to install the same bulid of 3D slicer as ubuntu (4.13.0 2021-09-29) in windows 7 but it failed to start 3D slicer when launching, the error message is:

SlicerApp-real.exe stopped to work
Error module name: ucrtbase.DLL

How can I fix these issue and use the MONAI label at windows 3D slicer?
Thank you.

1 Like

2021-08-16 version is almost 6 weeks old and features are added/bugs are fixed at a rapid pace in MONAILabel. Use the latest Slicer Preview Release and let us know if you run into any issues.

Windows 7 is going to be a problem when trying to use latest Slicer Preview. See the below information

Thank you sir for instant reply

I tried to install the latest bulid of 3D slicer 4.13.0 2021-09-28 in windows 7, same latest build as ubuntu; but it failed to start 3D slicer when launching, even under the previous build at 2021-09-21

the error message (partial) is:
SlicerApp-real.exe has stopped to work
Error module name: ucrtbase.DLL

The 4.13.0 2021-08-16 build is one build that can lanuch normally

Supporting old hardware and operating systems have very high cost and very low value, therefore we generally stay away from it.

You can try all Slicer releases between 08-16 and 09-21 and see which exact day the startup started to fail. Then you can build Slicer from source code and confirm which exact commit made the difference and build Slicer without that change. Note that if you build Slicer then it means that you also need to build all extensions. These are all doable, but will most likely you will need to invest several days of work into it, therefore it may be cheaper to buy a used (not more than 3-year-old) computer that is compatible with current Windows version.

@ragwing_mmh have you been able to resolve the fetch issue? I have the similar Slicer version and I tried installing it on Mac, It throws the same error as you mentioned and I was wondering if were able to bypass this issue. If yes, kind share with us how you resolved it. It was be a great help. Thank you.

here the error if it helps

Traceback (most recent call last):
File “/Applications/”, line 949, in fetchInfo
info =
File “/Applications/”, line 1965, in info
return MONAILabelClient(self.server_url, self.tmpdir, self.client_id).info()
File “/Applications/”, line 47, in info
status, response, _ = MONAILabelUtils.http_method(“GET”, self._server_url, selector)
File “/Applications/”, line 260, in http_method
conn.request(method, selector, body=body, headers=headers)
File “/Applications/”, line 1285, in request
self._send_request(method, url, body, headers, encode_chunked)
File “/Applications/”, line 1331, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “/Applications/”, line 1280, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “/Applications/”, line 1040, in _send_output
File “/Applications/”, line 980, in send
File “/Applications/”, line 946, in connect
self.sock = self._create_connection(
File “/Applications/”, line 844, in create_connection
raise err
File “/Applications/”, line 832, in create_connection
ConnectionRefusedError: [Errno 61] Connection refused