Fiducial awol under 2D view but not 3D

Dear All,

Just upgraded from 4.10 to latest stable version 4.11.20210226

My old 4.10 scenes open up ok but strangely I can not see my fiducial markers in the 2D views. They do appear ok in the 3D view, just missing altogether from the 2D slice views.

If I create a new set they do appear in 2D and 3D (identical settings). I have tried all the settings under “2D display”

Bit of a puzzle and would be a shame to revert back to an older version so I can continue working with my exisitng fiducials. Any ideas?

I should note one, possibly related observation: my data is in nrrd format. Under 4.10 the coronal and sagittal views were the wrong way round. Didn’t matter to me. Under 4.11 the views are correct. I wonder if this has scuppered the fiducials.

This is due to a new feature that 2D visibility of markups are now taken into account (see details here). You can either switch to a recent Slicer Preview Release or enable 2D visibility for the fiducials manually (by right-clicking on the eye icon of the markups node in Data module).

1 Like

Fab, thanks Andras. That worked - I can see them!

I did do a search for the problem but didn’t find your earlier post to Radek’s query - apologies for making you repeat!

Loving the additional markup functions

1 Like